]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/debian-mingw64/rules
ncurses 6.5 - patch 20240608
[ncurses.git] / test / package / debian-mingw64 / rules
index d0f17cddbfa78cf7beaf6b55b44e969bf34f992c..571b9a7edf081c0e979590922a4ddbd2e51cbeaa 100755 (executable)
@@ -1,5 +1,5 @@
 #!/usr/bin/make -f
-# MAde with the aid of dh_make, by Craig Small
+# Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Cristoph Lameter.
 
@@ -14,6 +14,8 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 CC_NORMAL = -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
 CC_STRICT = $(CC_NORMAL) -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
 
+NCURSES_PKG = ncurses-examples
+
 TARGET    = x86_64-w64-mingw32
 MINGW_BIN = /usr/bin
 MINGW_TOP = /usr/$(TARGET)
@@ -39,7 +41,9 @@ configure-stamp:
                --host=$(TARGET) \
                --target=$(TARGET) \
                --prefix=$(MINGW_TOP) \
-               --with-screen=ncursesw6 \
+               --bindir=\$${prefix}/bin/$(NCURSES_PKG) \
+               --datadir=\$${prefix}/share/$(NCURSES_PKG) \
+               --with-screen=ncursesw6td \
                --with-pkg-config-libdir=/usr/$(TARGET)/lib/pkgconfig
 
        touch configure-stamp
@@ -66,7 +70,7 @@ install: install-stamp
 install-stamp: build-stamp
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        $(MAKE) install DESTDIR=$(MINGW_TMP)