]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/ncurses-examples.spec
ncurses 6.4 - patch 20230225
[ncurses.git] / test / package / ncurses-examples.spec
index aeaca251297b9ef696d9a2c5486fbd30799a8fa2..8f1a3cbe52d133b84c7dc9a83e6d38929005c265 100644 (file)
@@ -3,15 +3,14 @@ Summary: example/test programs from ncurses
 %global AltProgram ncursest-examples
 %global AppVersion MAJOR.MINOR
 %global AppRelease YYYYMMDD
-# $Id: ncurses-examples.spec,v 1.14 2019/02/03 01:17:27 tom Exp $
+# $Id: ncurses-examples.spec,v 1.22 2023/02/25 23:10:49 tom Exp $
 Name: %{AppProgram}
 Version: %{AppVersion}
 Release: %{AppRelease}
 License: MIT
 Group: Applications/Development
-URL: ftp://ftp.invisible-island.net/%{AppProgram}
-Source0: %{AppProgram}-%{AppRelease}.tgz
-Packager: Thomas Dickey <dickey@invisible-island.net>
+URL: https://invisible-island.net/ncurses/%{AppProgram}.html
+Source: https://invisible-island.net/archives/%{AppProgram}/%{AppProgram}-%{release}.tgz
 
 %description
 These are the example/test programs from the ncurses MAJOR.MINOR distribution,
@@ -50,8 +49,7 @@ CONFIGURE_TOP=%{my_srcdir} \
 %configure \
        --target %{_target_platform} \
        --prefix=%{_prefix} \
-       --bindir=%{_bindir}/%{AppProgram} \
-       --datadir=%{_datadir}/%{AppProgram} \
+       --datadir=%{_datarootdir}/%{AppProgram} \
        --with-screen=ncursesw6dev \
        --disable-rpath-hack
 
@@ -66,8 +64,7 @@ CONFIGURE_TOP=%{my_srcdir} \
 %configure \
        --target %{_target_platform} \
        --prefix=%{_prefix} \
-       --bindir=%{_bindir}/%{AltProgram} \
-       --datadir=%{_datadir}/%{AltProgram} \
+       --datadir=%{_datarootdir}/%{AltProgram} \
        --with-screen=ncursestw6dev \
        --disable-rpath-hack
 
@@ -78,29 +75,37 @@ popd
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
 pushd BUILD-%{AppProgram}
-make install DESTDIR=$RPM_BUILD_ROOT
+make install PACKAGE=%{AppProgram} DESTDIR=$RPM_BUILD_ROOT
 popd
 
 pushd BUILD-%{AltProgram}
-make install DESTDIR=$RPM_BUILD_ROOT
+make install PACKAGE=%{AltProgram} DESTDIR=$RPM_BUILD_ROOT
 popd
 
-%clean
-[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
-
 %files -n %{AppProgram}
 %defattr(-,root,root)
-%{_bindir}/%{AppProgram}/*
-%{_datadir}/%{AppProgram}/*
+%{_bindir}/%{AppProgram}
+%{_libexecdir}/%{AppProgram}/*
+%{_datarootdir}/%{AppProgram}/*
 
 %files -n %{AltProgram}
 %defattr(-,root,root)
-%{_bindir}/%{AltProgram}/*
-%{_datadir}/%{AltProgram}/*
+%{_bindir}/%{AltProgram}
+%{_libexecdir}/%{AltProgram}/*
+%{_datarootdir}/%{AltProgram}/*
 
 %changelog
 # each patch should add its ChangeLog entries here
 
+* Sat Feb 25 2023 Thomas Dickey
+- amend URLs per rpmlint
+
+* Sat Dec 18 2021 Thomas Dickey
+- use libexecdir for programs rather than subdir of bindir
+
+* Sat Nov 16 2019 Thomas Dickey
+- modify clean-rule to work around Fedora NFS bugs.
+
 * Sat Nov 11 2017 Thomas Dickey
 - add example data-files
 - use rpm built-in "configure"