]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses.spec
c98e104709717ed0650842dde9f8d1f76cd8b53c
[ncurses.git] / Ada95 / package / AdaCurses.spec
1 Summary: AdaCurses - Ada95 binding for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: AdaCurses.spec,v 1.12 2011/04/01 00:08:32 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 This is the Ada95 binding from the ncurses MAJOR.MINOR distribution, for
17 patch-date YYYYMMDD.
18
19 In addition to a library, this package installs sample programs in
20 "bin/AdaCurses" to avoid conflict with other packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %build
26
27 %define ada_libdir %{_prefix}/lib/ada/adalib
28
29 INSTALL_PROGRAM='${INSTALL}' \
30         ./configure \
31                 --target %{_target_platform} \
32                 --prefix=%{_prefix} \
33                 --bindir=%{_bindir} \
34                 --libdir=%{_libdir} \
35                 --mandir=%{_mandir} \
36                 --datadir=%{_datadir} \
37                 --disable-rpath-link \
38                 --with-shared \
39                 --with-ada-sharedlib
40
41 make
42
43 %install
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 make install               DESTDIR=$RPM_BUILD_ROOT
47
48 ( cd samples &&
49   make install.examples \
50         DESTDIR=$RPM_BUILD_ROOT \
51         BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
52 )
53
54 %clean
55 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(-,root,root)
59 %{_bindir}/adacurses*-config
60 %{_bindir}/%{AppProgram}/*
61 %{_libdir}/libAdaCurses.*
62 %{ada_libdir}/libAdaCurses.*
63 %{ada_libdir}/terminal_interface*
64 %{_mandir}/man1/adacurses*-config.1*
65 %{_datadir}/%{AppProgram}/*
66 %{_datadir}/ada/adainclude/terminal_interface*
67
68 %changelog
69 # each patch should add its ChangeLog entries here
70
71 * Thu Mar 31 2010 Thomas Dickey
72 - use --with-shared option for consistency with --with-ada-sharelib
73 - ensure that MY_DATADIR is set when installing examples
74 - add ada_libdir symbol to handle special case where libdir is /usr/lib64
75 - use --disable-rpath-link to link sample programs without rpath
76
77 * Fri Mar 25 2010 Thomas Dickey
78 - initial version