]> ncurses.scripts.mit.edu Git - ncurses.git/blob - package/mingw-ncurses.spec
b4fcf8c0020e6ac5299b1ae5877f7a3fb3a976c8
[ncurses.git] / package / mingw-ncurses.spec
1 %?mingw_package_header
2
3 Summary: shared libraries for terminal handling
4 Name: mingw32-ncurses6
5 Release: 5.9
6 Version: 20130805
7 License: X11
8 Group: Development/Libraries
9 Source: ncurses-%{release}-%{version}.tgz
10 # URL: http://invisible-island.net/ncurses/
11
12 BuildRequires:  mingw32-filesystem >= 95
13 BuildRequires:  mingw32-gcc
14 BuildRequires:  mingw32-binutils
15
16 BuildRequires:  mingw64-filesystem >= 95
17 BuildRequires:  mingw64-gcc
18 BuildRequires:  mingw64-binutils
19
20 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
21 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
22
23 %description -n mingw32-ncurses6
24 Cross-compiling support for ncurses to mingw32.
25
26 The ncurses library routines are a terminal-independent method of
27 updating character screens with reasonable optimization.
28
29 This package is used for testing ABI 6 with cross-compiles to MinGW.
30
31 %package -n mingw64-ncurses6
32 Summary:        Curses library for MinGW64
33
34 %description -n mingw64-ncurses6
35 Cross-compiling support for ncurses to mingw64.
36
37 The ncurses library routines are a terminal-independent method of
38 updating character screens with reasonable optimization.
39
40 This package is used for testing ABI 6 with cross-compiles to MinGW.
41
42 %prep
43
44 %define CFG_OPTS \\\
45         --disable-echo \\\
46         --disable-db-install \\\
47         --disable-getcap \\\
48         --disable-hard-tabs \\\
49         --disable-leaks \\\
50         --disable-macros \\\
51         --disable-overwrite \\\
52         --disable-termcap \\\
53         --enable-const \\\
54         --enable-ext-colors \\\
55         --enable-ext-mouse \\\
56         --enable-interop \\\
57         --enable-sp-funcs \\\
58         --enable-term-driver \\\
59         --enable-warnings \\\
60         --enable-widec \\\
61         --verbose \\\
62         --with-cxx-shared \\\
63         --with-develop \\\
64         --with-fallbacks=unknown,rxvt \\\
65         --with-shared \\\
66         --with-tparm-arg=intptr_t \\\
67         --with-trace \\\
68         --with-xterm-kbs=DEL \\\
69         --without-ada \\\
70         --without-debug \\\
71         --with-install-prefix=$RPM_BUILD_ROOT \\\
72         --without-manpages \\\
73         --without-tests
74
75 %define debug_package %{nil}
76 %setup -q -n ncurses-%{release}-%{version}
77
78 %build
79 mkdir BUILD-W32
80 pushd BUILD-W32
81 CFLAGS="%{CC_NORMAL}" \
82 CC=%{mingw32_cc} \
83 %mingw32_configure %{CFG_OPTS}
84 make
85 popd
86
87 mkdir BUILD-W64
88 pushd BUILD-W64
89 CFLAGS="%{CC_NORMAL}" \
90 CC=%{mingw64_cc} \
91 %mingw64_configure %{CFG_OPTS}
92 make
93 popd
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 pushd BUILD-W32
99 %{mingw32_make} install
100 popd
101
102 pushd BUILD-W64
103 %{mingw64_make} install
104 popd
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(-,root,root,-)
111
112 %files -n mingw32-ncurses6
113 %{mingw32_bindir}/*
114 %{mingw32_includedir}/*
115 %{mingw32_libdir}/*
116
117 %files -n mingw64-ncurses6
118 %{mingw64_bindir}/*
119 %{mingw64_includedir}/*
120 %{mingw64_libdir}/*
121
122 %changelog
123
124 * Sat Aug 03 2013 Thomas E. Dickey
125 - initial version, using mingw-pdcurses package as a guide.