]> ncurses.scripts.mit.edu Git - ncurses.git/blob - test/package/debian/rules
ncurses 6.0 - patch 20170722
[ncurses.git] / test / package / debian / rules
1 #!/usr/bin/make -f
2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # packages
10 NCURSES_PKG = ncurses-examples
11 NCURSEST_PKG = ncursest-examples
12
13 PACKAGES.indep = # ncurses-examples-docs
14 PACKAGES.arch  = $(NCURSES_PKG) $(NCURSEST_PKG)
15
16 # These are used for cross-compiling and for saving the configure script
17 # from having to guess our platform (since we know it already)
18 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
19 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
20
21 CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
22 CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
23 LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
24
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26         CFLAGS += -O0
27 else
28         CFLAGS += -O2
29 endif
30 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
31         INSTALL_PROGRAM += -s
32 endif
33
34 verbose = # -v
35
36 configure = \
37         CFLAGS="$(CFLAGS)" \
38         CPPFLAGS="$(CPPFLAGS)" \
39         LDFLAGS="$(LDFLAGS)" ../../configure \
40                 --host=$(DEB_HOST_GNU_TYPE) \
41                 --build=$(DEB_BUILD_GNU_TYPE) \
42                 --prefix=/usr \
43                 --disable-rpath-hack
44
45 .PHONY: all config build install binary clean config-indep config-arch \
46     build-indep build-arch install-indep install-arch binary-indep \
47     binary-arch
48
49 all: build
50
51 config: config-indep config-arch
52 build: build-indep build-arch
53 install: install-indep install-arch
54 binary: binary-indep binary-arch
55 clean:
56         dh_testdir
57         dh_testroot
58         dh_clean $(verbose)
59         rm -rf t
60
61 config-indep: $(PACKAGES.indep:%=config-%-stamp)
62 config-arch: $(PACKAGES.arch:%=config-%-stamp)
63
64 build-indep: $(PACKAGES.indep:%=build-%-stamp)
65 build-arch: $(PACKAGES.arch:%=build-%-stamp)
66
67 install-indep: $(PACKAGES.indep:%=install-%-stamp)
68 install-arch: $(PACKAGES.arch:%=install-%-stamp)
69
70 config-$(NCURSES_PKG)-stamp:
71         dh_testdir
72
73         rm -rf t/ncurses6
74         mkdir -p t/ncurses6
75
76         cd t/ncurses6; $(configure) \
77                 --bindir=\$${prefix}/bin/$(NCURSES_PKG) \
78                 --with-screen=ncursesw6
79
80         touch $@
81
82 config-$(NCURSEST_PKG)-stamp:
83         dh_testdir
84
85         rm -rf t/ncursest6
86         mkdir -p t/ncursest6
87
88         cd t/ncursest6; $(configure) \
89                 --bindir=\$${prefix}/bin/$(NCURSEST_PKG) \
90                 --with-screen=ncursestw6
91
92         touch $@
93
94 build-$(NCURSES_PKG)-stamp: config-$(NCURSES_PKG)-stamp
95         dh_testdir
96
97         $(MAKE) -C t/ncurses6
98
99         touch $@
100
101 build-$(NCURSEST_PKG)-stamp: config-$(NCURSEST_PKG)-stamp
102         dh_testdir
103
104         $(MAKE) -C t/ncursest6
105
106         touch $@
107
108 install-$(NCURSES_PKG)-stamp: build-$(NCURSES_PKG)-stamp
109         dh_testdir
110         dh_testroot
111         dh_installdirs $(verbose)
112         dh_prep        $(verbose) -p$(NCURSES_PKG)
113
114         $(MAKE) -C t/ncurses6 install DESTDIR=$(CURDIR)/debian/$(NCURSES_PKG)
115
116         touch $@
117
118 install-$(NCURSEST_PKG)-stamp: build-$(NCURSEST_PKG)-stamp
119         dh_testdir
120         dh_testroot
121         dh_installdirs $(verbose)
122         dh_prep        $(verbose) -p$(NCURSEST_PKG)
123
124         $(MAKE) -C t/ncursest6 install DESTDIR=$(CURDIR)/debian/$(NCURSEST_PKG)
125
126         touch $@
127
128 # Build architecture-independent files here.
129 binary-indep: install-indep
130 ifneq ($(PACKAGES.indep),)
131         rm -f $(PACKAGES.indep:%=install-%-stamp)
132         dh_testdir
133         dh_testroot
134         dh_installdocs       $(verbose) $(PACKAGES.indep:%=-p%)
135         dh_installman        $(verbose) $(PACKAGES.indep:%=-p%)
136         dh_installexamples   $(verbose) $(PACKAGES.indep:%=-p%)
137         dh_installchangelogs $(verbose) $(PACKAGES.indep:%=-p%) NEWS
138         dh_compress          $(verbose) $(PACKAGES.indep:%=-p%)
139         dh_fixperms          $(verbose) $(PACKAGES.indep:%=-p%)
140         dh_installdeb        $(verbose) $(PACKAGES.indep:%=-p%)
141         dh_gencontrol        $(verbose) $(PACKAGES.indep:%=-p%)
142         dh_md5sums           $(verbose) $(PACKAGES.indep:%=-p%)
143         dh_builddeb          $(verbose) $(PACKAGES.indep:%=-p%)
144 endif
145
146 # Build architecture-dependent files here.
147 binary-arch: install-arch
148 ifneq ($(PACKAGES.arch),)
149         rm -f $(PACKAGES.arch:%=install-%-stamp)
150         dh_testdir
151         dh_testroot
152         dh_installchangelogs $(verbose) $(PACKAGES.arch:%=-p%)  NEWS
153         dh_strip             $(verbose) $(PACKAGES.arch:%=-p%)
154         dh_compress          $(verbose) $(PACKAGES.arch:%=-p%)
155         dh_fixperms          $(verbose) $(PACKAGES.arch:%=-p%)
156         dh_installdeb        $(verbose) $(PACKAGES.arch:%=-p%)
157         dh_makeshlibs        $(verbose) $(PACKAGES.arch:%=-p%)
158         dh_shlibdeps         $(verbose) $(PACKAGES.arch:%=-p%)
159         dh_gencontrol        $(verbose) $(PACKAGES.arch:%=-p%)
160         dh_md5sums           $(verbose) $(PACKAGES.arch:%=-p%)
161         dh_builddeb          $(verbose) $(PACKAGES.arch:%=-p%)
162 endif