]> ncurses.scripts.mit.edu Git - ncurses.git/blob - test/package/ncurses-examples.spec
1918777aaf0f419a8f19707ef21657eed44e072e
[ncurses.git] / test / package / ncurses-examples.spec
1 Summary: ncurses-examples - example/test programs from ncurses
2 %define AppProgram ncurses-examples
3 %define AppVersion 6.0
4 %define AppRelease 20171111
5 # $Id: ncurses-examples.spec,v 1.8 2017/12/09 20:41:16 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://ftp.invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 These are the example/test programs from the ncurses 6.0 distribution,
17 for patch-date 20171111.
18
19 This package installs in "bin/ncurses-examples" to avoid conflict with other
20 packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %define debug_package %{nil}
26
27 %build
28
29 INSTALL_PROGRAM='${INSTALL}' \
30 %configure \
31         --target %{_target_platform} \
32         --prefix=%{_prefix} \
33         --bindir=%{_bindir}/%{AppProgram} \
34         --datadir=%{_datadir}/%{AppProgram} \
35         --with-screen=ncursesw6 \
36         --disable-rpath-hack
37
38 make
39
40 %install
41 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
42
43 make install               DESTDIR=$RPM_BUILD_ROOT
44
45 strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}/*
46
47 %clean
48 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(-,root,root)
52 %{_bindir}/%{AppProgram}/*
53 %{_datadir}/%{AppProgram}/*
54
55 %changelog
56 # each patch should add its ChangeLog entries here
57
58 * Sat Nov 11 2017 Thomas Dickey
59 - add example data-files
60 - use rpm built-in "configure"
61 - suppress debug-package
62
63 * Thu Mar 25 2010 Thomas Dickey
64 - initial version