]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.1 - patch 20200111
[ncurses.git] / Ada95 / configure.in
index b7d3b76e4995b609c61bca1683bbce6bb5835eb7..21624e1521cfa0d1960b2027a2cedbc030f92e12 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 2010-2018,2019 Free Software Foundation, Inc.              *
+dnl Copyright (c) 2010-2019,2020 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,17 +28,21 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.71 2019/08/31 21:16:49 tom Exp $
+dnl $Id: configure.in,v 1.74 2020/01/11 23:33:38 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
-dnl See https://invisible-island.net/autoconf/ for additional information.
+dnl For additional information, see
+dnl     https://invisible-island.net/autoconf/
+dnl     https://invisible-island.net/autoconf/my-autoconf.html
 dnl
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.52.20030208)
-AC_REVISION($Revision: 1.71 $)
+AC_PREREQ(2.52.20200111)
+AC_REVISION($Revision: 1.74 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
+AC_DEFUN([AC_PATH_XTRA],[])dnl ignore dependencies on this
+
 CF_TOP_BUILDDIR
 
 CF_HELP_MESSAGE(General Options:)
@@ -497,6 +501,9 @@ if test "$cf_with_ada" != "no" ; then
                CF_WITH_ADA_INCLUDE
                CF_WITH_ADA_OBJECTS
                CF_WITH_ADA_SHAREDLIB
+
+               # allow the Ada binding to be renamed
+               CF_WITH_ADA_LIBNAME(AdaCurses)
        else
                AC_MSG_ERROR(No usable Ada compiler found)
        fi
@@ -606,6 +613,7 @@ AC_SUBST(ADAGEN_LDFLAGS)
 
 AC_OUTPUT( \
        $SUB_MAKEFILES \
+       src/library.gpr:src/library.gpr.in \
        doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in \
        Makefile,[
 if test -z "$USE_OLD_MAKERULES" ; then