]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 5.7 - patch 20110122
[ncurses.git] / Ada95 / configure.in
index edc9265e5de8264e0e203ac0a9f318e3655019d4..3b72139548251b07977d9220914b5bd5ea379633 100644 (file)
@@ -28,14 +28,14 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.17 2010/07/17 19:56:25 tom Exp $
+dnl $Id: configure.in,v 1.21 2010/11/06 22:11:21 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
 dnl See http://invisible-island.net/autoconf/ for additional information.
 dnl
 dnl ---------------------------------------------------------------------------
 AC_PREREQ(2.13.20020210)
-AC_REVISION($Revision: 1.17 $)
+AC_REVISION($Revision: 1.21 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
@@ -69,7 +69,7 @@ AC_ARG_PROGRAM
 CF_PROG_AWK
 CF_PROG_EGREP
 AC_PROG_INSTALL
-AC_PROG_LN_S
+CF_PROG_LN_S
 
 AC_SYS_LONG_FILE_NAMES
 
@@ -98,6 +98,13 @@ if test "$PKG_CONFIG" != no ; then
 fi
 AC_SUBST(PKG_CONFIG_LIBDIR)
 
+AC_MSG_CHECKING(if you want to build test-programs)
+AC_ARG_WITH(tests,
+       [  --without-tests         suppress build with test-programs],
+       [cf_with_tests=$withval],
+       [cf_with_tests=yes])
+AC_MSG_RESULT($cf_with_tests)
+
 AC_MSG_CHECKING(if we should assume mixed-case filenames)
 AC_ARG_ENABLE(mixed-case,
        [  --enable-mixed-case     tic should assume mixed-case filenames],
@@ -209,7 +216,7 @@ AC_MSG_CHECKING(if you want broken-linker support code)
 AC_ARG_ENABLE(broken_linker,
        [  --enable-broken_linker  compile with broken-linker support code],
        [with_broken_linker=$enableval],
-       [with_broken_linker=${BROKEN_LINKER-no}])
+       [with_broken_linker=${BROKEN_LINKER:-no}])
 AC_MSG_RESULT($with_broken_linker)
 
 BROKEN_LINKER=0
@@ -568,7 +575,10 @@ dnl for separate build, this is good enough for "sh $(top_srcdir)/misc/shlib"
 NCURSES_SHLIB2="sh -c"
 AC_SUBST(NCURSES_SHLIB2)
 
-ADA_SUBDIRS="include gen src samples"
+ADA_SUBDIRS="include gen src"
+if test "x$cf_with_tests" != "xno" ; then
+       ADA_SUBDIRS="$ADA_SUBDIRS samples"
+fi
 for cf_dir in $ADA_SUBDIRS
 do
        SUB_MAKEFILES="$SUB_MAKEFILES $cf_dir/Makefile"
@@ -597,6 +607,7 @@ DFT_LWR_MODEL="$DFT_LWR_MODEL"
 ECHO_LINK="$ECHO_LINK"
 LIB_NAME="$LIB_NAME"
 LIB_SUFFIX="$LIB_SUFFIX"
+LN_S="$LN_S"
 NCURSES_MAJOR="$NCURSES_MAJOR"
 NCURSES_MINOR="$NCURSES_MINOR"
 NCURSES_PATCH="$NCURSES_PATCH"
@@ -612,4 +623,4 @@ host="$host"
 target="$target"
 
 ],cat)dnl
-${MAKE-make} preinstall
+${MAKE:-make} preinstall