]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.1 - patch 20190907
[ncurses.git] / Ada95 / configure.in
index 19698c5ab7fb6e8bcd3acc9b6e1b71f7b6859821..90b163ba01fc119c88cf90e1402fd9d3dffda218 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 2010-2014,2015 Free Software Foundation, Inc.              *
+dnl Copyright (c) 2010-2018,2019 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,19 +28,21 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.61 2015/09/19 20:33:36 tom Exp $
+dnl $Id: configure.in,v 1.72 2019/09/07 22:50:06 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
-dnl See http://invisible-island.net/autoconf/ for additional information.
+dnl See https://invisible-island.net/autoconf/ for additional information.
 dnl
 dnl ---------------------------------------------------------------------------
 AC_PREREQ(2.52.20030208)
-AC_REVISION($Revision: 1.61 $)
+AC_REVISION($Revision: 1.72 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
 CF_TOP_BUILDDIR
 
+CF_HELP_MESSAGE(General Options:)
+
 CF_WITH_SYSTYPE
 
 ###    Save the given $CFLAGS to allow user-override.
@@ -53,7 +55,7 @@ CF_CFG_DEFAULTS
 CF_PROG_CC(gnatgcc gcc cc)
 AC_PROG_CPP
 AC_PROG_GCC_TRADITIONAL
-CF_PROG_CC_C_O(CC)
+CF_PROG_CC_C_O(CC,[$CFLAGS $CPPFLAGS])
 
 AC_ARG_PROGRAM
 
@@ -62,6 +64,9 @@ CF_PROG_EGREP
 AC_PROG_INSTALL
 CF_PROG_LN_S
 
+CF_PROG_INSTALL
+CF_INSTALL_OPTS
+
 AC_SYS_LONG_FILE_NAMES
 
 # if we find pkg-config, check if we should install the ".pc" files.
@@ -228,7 +233,7 @@ fi
 AC_SUBST(BROKEN_LINKER)
 
 # Check to define _XOPEN_SOURCE "automatically"
-CF_XOPEN_SOURCE
+CF_XOPEN_SOURCE(600)
 
 CF_LARGEFILE
 
@@ -492,6 +497,9 @@ if test "$cf_with_ada" != "no" ; then
                CF_WITH_ADA_INCLUDE
                CF_WITH_ADA_OBJECTS
                CF_WITH_ADA_SHAREDLIB
+
+               # allow the Ada binding to be renamed
+               CF_WITH_ADA_LIBNAME(AdaCurses)
        else
                AC_MSG_ERROR(No usable Ada compiler found)
        fi
@@ -540,6 +548,12 @@ if test "$DFT_LWR_MODEL" = shared ; then
        esac
 fi
 
+USE_ARG_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_ARG_SUFFIX)
+
+USE_LIB_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_LIB_SUFFIX)
+
 USE_CFG_SUFFIX=${DFT_ARG_SUFFIX}
 AC_SUBST(USE_CFG_SUFFIX)