]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.3 - patch 20211030
[ncurses.git] / Ada95 / configure.in
index f0f1e5482fbe5d2e76d746182a9af65f2585c83e..a69c183302054781702e83f9117e2bd558ebb424 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright 2018-2019,2020 Thomas E. Dickey                                *
+dnl Copyright 2018-2020,2021 Thomas E. Dickey                                *
 dnl Copyright 2010-2016,2018 Free Software Foundation, Inc.                  *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
@@ -29,7 +29,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.79 2020/12/05 21:40:57 tom Exp $
+dnl $Id: configure.in,v 1.84 2021/10/30 20:47:52 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
 dnl For additional information, see
@@ -37,8 +37,8 @@ dnl     https://invisible-island.net/autoconf/
 dnl     https://invisible-island.net/autoconf/my-autoconf.html
 dnl
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.52.20200111)
-AC_REVISION($Revision: 1.79 $)
+AC_PREREQ(2.52.20210509)
+AC_REVISION($Revision: 1.84 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
@@ -102,6 +102,7 @@ fi
 
 # do this after mixed-case option (tags/TAGS is not as important as tic).
 AC_PROG_MAKE_SET
+CF_MAKE_PHONY
 CF_MAKE_TAGS
 CF_MAKEFLAGS
 
@@ -353,15 +354,8 @@ CF_HELP_MESSAGE(Testing/development Options:)
 ###    use option --disable-echo to suppress full display compiling commands
 CF_DISABLE_ECHO
 
-###    use option --enable-warnings to turn on all gcc warnings
-AC_MSG_CHECKING(if you want to see compiler warnings)
-AC_ARG_ENABLE(warnings,
-       [  --enable-warnings       build: turn on GCC compiler warnings],
-       [with_warnings=$enableval])
-AC_MSG_RESULT($with_warnings)
-
 CF_ENABLE_WARNINGS(Wno-unknown-pragmas Wswitch-enum,yes)
-if test "x$with_warnings" = "xyes"; then
+if test "x$enable_warnings" = "xyes"; then
        CF_ADD_ADAFLAGS(-gnatg)
 fi
 
@@ -425,6 +419,7 @@ CF_DISABLE_GNAT_PROJECTS
 ###    Checks for libraries.
 case $cf_cv_system_name in
 (*mingw32*)
+       CF_CHECK_LIBSSP
        ;;
 (*)
 AC_CHECK_FUNC(gettimeofday,