ncurses 6.2 - patch 20210102
[ncurses.git] / NEWS
diff --git a/NEWS b/NEWS
index 8eb99de70b6e2ee2b51f936135790bad0a6e24d9..ed85f6fa59b648f600d535441596f41b8a1f0c54 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,5 @@
 -------------------------------------------------------------------------------
--- Copyright 2018-2019,2020 Thomas E. Dickey                                 --
+-- Copyright 2018-2020,2021 Thomas E. Dickey                                 --
 -- Copyright 1998-2017,2018 Free Software Foundation, Inc.                   --
 --                                                                           --
 -- Permission is hereby granted, free of charge, to any person obtaining a   --
@@ -26,7 +26,7 @@
 -- sale, use or other dealings in this Software without prior written        --
 -- authorization.                                                            --
 -------------------------------------------------------------------------------
--- $Id: NEWS,v 1.3610 2020/12/27 23:49:02 tom Exp $
+-- $Id: NEWS,v 1.3614 2021/01/02 23:56:42 tom Exp $
 -------------------------------------------------------------------------------
 
 This is a log of changes that ncurses has gone through since Zeyd started
@@ -46,6 +46,18 @@ See the AUTHORS file for the corresponding full names.
 Changes through 1.9.9e did not credit all contributions;
 it is not possible to add this information.
 
+20210102
+       + update man/curs_memleaks.3x, to include <term.h> which declares
+         exit_terminfo.
+       + clarify man/curs_terminfo.3x, to mention why the macro setterm is
+         defined in <curses.h>, and remove it from the list of prototypes
+         (prompted by patch by Graeme McCutcheon).
+       + amend man/curs_terminfo.3x, to note that <curses.h> is required
+         for certain functions, e.g., those using chtype or attr_t for
+         types, as well as mvcur (cf: 20201031).
+       + use parameter-names in prototypes in curs_sp_funcs.3x, for
+         consistency with other manpages.
+
 20201227
        + update terminology entry to 1.8.1 -TD
        + fix some compiler-warnings which gcc8 reports incorrectly.