]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/mingw-ncurses.spec
ncurses 6.1 - patch 20180129
[ncurses.git] / package / mingw-ncurses.spec
index 62da2e0b6cca623fda47fb7e900b9404143ac643..5a1d83793416a19ba3053e8647714d6e1198a251 100644 (file)
@@ -2,12 +2,12 @@
 
 Summary: shared libraries for terminal handling
 Name: mingw32-ncurses6
-Version: 6.0
-Release: 20170212
+Version: 6.1
+Release: 20180129
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
-# URL: http://invisible-island.net/ncurses/
+# URL: https://invisible-island.net/ncurses/
 
 BuildRequires:  mingw32-filesystem >= 95
 BuildRequires:  mingw32-gcc
@@ -17,6 +17,8 @@ BuildRequires:  mingw64-filesystem >= 95
 BuildRequires:  mingw64-gcc
 BuildRequires:  mingw64-binutils
 
+%global MY_ABI 6
+
 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
 
@@ -37,13 +39,13 @@ Cross-compiling support for ncurses to mingw64.
 The ncurses library routines are a terminal-independent method of
 updating character screens with reasonable optimization.
 
-This package is used for testing ABI 6 with cross-compiles to MinGW.
+This package is used for testing ABI %{MY_ABI} with cross-compiles to MinGW.
 
 %prep
 
 %define CFG_OPTS \\\
-       --disable-echo \\\
        --disable-db-install \\\
+       --disable-echo \\\
        --disable-getcap \\\
        --disable-hard-tabs \\\
        --disable-leaks \\\
@@ -55,21 +57,24 @@ This package is used for testing ABI 6 with cross-compiles to MinGW.
        --enable-ext-mouse \\\
        --enable-ext-putwin \\\
        --enable-interop \\\
+       --enable-pc-files \\\
        --enable-sp-funcs \\\
        --enable-term-driver \\\
        --enable-warnings \\\
        --enable-widec \\\
+       --with-config-suffix=dev \\\
        --verbose \\\
        --with-cxx-shared \\\
        --with-develop \\\
        --with-fallbacks=unknown,rxvt \\\
+       --with-install-prefix=$RPM_BUILD_ROOT \\\
+       --with-pc-suffix=%{MY_ABI} \\\
        --with-shared \\\
        --with-tparm-arg=intptr_t \\\
        --with-trace \\\
        --with-xterm-kbs=DEL \\\
        --without-ada \\\
        --without-debug \\\
-       --with-install-prefix=$RPM_BUILD_ROOT \\\
        --without-manpages \\\
        --without-progs \\\
        --without-tests
@@ -82,7 +87,8 @@ mkdir BUILD-W32
 pushd BUILD-W32
 CFLAGS="%{CC_NORMAL}" \
 CC=%{mingw32_cc} \
-%mingw32_configure %{CFG_OPTS}
+%mingw32_configure %{CFG_OPTS} \
+       --with-pkg-config-libdir=%{mingw32_libdir}/pkgconfig
 make
 popd
 
@@ -90,7 +96,8 @@ mkdir BUILD-W64
 pushd BUILD-W64
 CFLAGS="%{CC_NORMAL}" \
 CC=%{mingw64_cc} \
-%mingw64_configure %{CFG_OPTS}
+%mingw64_configure %{CFG_OPTS} \
+       --with-pkg-config-libdir=%{mingw64_libdir}/pkgconfig
 make
 popd
 
@@ -136,6 +143,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %changelog
 
+* Tue Dec 26 2017 Thomas E. Dickey
+- add --with-config-suffix option
+
 * Sat Sep 20 2014 Thomas E. Dickey
 - adjust install-rules for ncurses*-config