]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/ncurses.spec
ncurses 6.1 - patch 20190713
[ncurses.git] / package / ncurses.spec
index 6b99d7841e25c3704346019896a29f12e32cc495..2b3dc833fe27273310289d60617de463243b36bc 100644 (file)
@@ -1,7 +1,7 @@
 Summary: shared libraries for terminal handling
 Name: ncurses6
 Version: 6.1
-Release: 20180526
+Release: 20190713
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
@@ -27,22 +27,33 @@ updating character screens with reasonable optimization.
 
 This package is used for testing ABI %{MY_ABI}.
 
-%package -n ncursest6
-Summary:        Curses library with POSIX thread support.
+%prep
 
-%description -n ncursest6
-The ncurses library routines are a terminal-independent method of
-updating character screens with reasonable optimization.
+%global is_mandriva %(test -f /etc/mandriva-release && echo 1 || echo 0)
+%global is_redhat   %(test -f /etc/redhat-release && echo 1 || echo 0)
+%global is_suse     %(test -f /etc/SuSE-release && echo 1 || echo 0)
 
-This package is used for testing ABI %{MY_ABI} with POSIX threads.
+# nor are debug-symbols
+%define debug_package %{nil}
 
-%prep
+%if %{is_mandriva}
+%define _disable_ld_as_needed 1
+%define _disable_ld_no_undefined 1
+# libtool is not used here...
+%define _disable_libtoolize 1
+%define _disable_ld_build_id 1
+%endif
+
+%if %{is_redhat}
+# workaround for toolset breakage in Fedora 28
+%define _test_relink --enable-relink
+%else
+%define _test_relink --disable-relink
+%endif
 
-%define debug_package %{nil}
 %setup -q -n ncurses-%{version}-%{release}
 
 %build
-%define my_srcdir ..
 %define CFG_OPTS \\\
        --target %{_target_platform} \\\
        --prefix=%{_prefix} \\\
@@ -55,6 +66,7 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
        --disable-leaks \\\
        --disable-macros  \\\
        --disable-overwrite  \\\
+       %{_test_relink}  \\\
        --disable-termcap \\\
        --enable-hard-tabs \\\
        --enable-opaque-curses \\\
@@ -88,79 +100,37 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
        --without-debug \\\
        --without-normal
 
-%global _configure ../configure
-
-mkdir BUILD-ncurses6
-pushd BUILD-ncurses6
 CFLAGS="%{CC_NORMAL}" \
 RPATH_LIST=../lib:%{_libdir} \
-CONFIGURE_TOP=%{my_srcdir} \
 %configure %{CFG_OPTS}
-make
-popd
 
-mkdir BUILD-ncursest6
-pushd BUILD-ncursest6
-CFLAGS="%{CC_NORMAL}" \
-RPATH_LIST=../lib:%{_libdir} \
-CONFIGURE_TOP=%{my_srcdir} \
-%configure %{CFG_OPTS} \
-       --enable-interop \
-       --enable-sp-funcs \
-       --program-suffix=t%{MY_ABI} \
-       --with-pthread
 make
-popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd BUILD-ncurses6
 make install.libs install.progs
 rm -f test/ncurses
 ( cd test && make ncurses LOCAL_LIBDIR=%{_libdir} && mv ncurses $RPM_BUILD_ROOT/%{_bindir}/ncurses%{MY_ABI} )
-popd
-
-pushd BUILD-ncursest6
-make install.libs install.progs
-rm -f test/ncurses
-( cd test && make ncurses LOCAL_LIBDIR=%{_libdir} && mv ncurses $RPM_BUILD_ROOT/%{_bindir}/ncursest%{MY_ABI} )
-popd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -n ncurses6
+%files
 %defattr(-,root,root,-)
 %{_bindir}/*
 %{_includedir}/*
 %{_libdir}/*
-%exclude %{_bindir}/tict6
-%exclude %{_bindir}/toet6
-%exclude %{_bindir}/tabst6
-%exclude %{_bindir}/resett6
-%exclude %{_bindir}/???*tt6
-%exclude %{_bindir}/?????*t6
-%exclude %{_bindir}/*tw6*
-%exclude %dir %{_includedir}/*tw6*
-%exclude %{_includedir}/*tw6*/*
-%exclude %{_libdir}/*tw6*
-%exclude %{_libdir}/pkgconfig/*tw6*
-
-%files -n ncursest6
-%defattr(-,root,root,-)
-%{_bindir}/tict6
-%{_bindir}/toet6
-%{_bindir}/tabst6
-%{_bindir}/???*tt6
-%{_bindir}/?????*t6
-%{_bindir}/*tw6*
-%{_includedir}/*tw6*
-%{_libdir}/*tw6*
-%{_libdir}/pkgconfig/*tw6*
 
 %changelog
 
+* Sat Aug 25 2018 Thomas E. Dickey
+- split spec-file into ncurses6 and ncursest6 to work around toolset breakage
+  in Fedora 28
+
+* Sat Jun 02 2018 Thomas E. Dickey
+- build-fix for Mageia
+
 * Sat May 26 2018 Thomas E. Dickey
 - use predefined configure-macro
 - separate ncurses6/ncursest6 packages