]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/ncurses.spec
ncurses 6.1 - patch 20180721
[ncurses.git] / package / ncurses.spec
index f285cf0d93b7a36c7c22e6e9b0f6e086fd8c9659..f4ce0fdf65eb796ea51d669db3788c70467e13e5 100644 (file)
@@ -1,7 +1,7 @@
 Summary: shared libraries for terminal handling
 Name: ncurses6
 Version: 6.1
-Release: 20180324
+Release: 20180721
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
@@ -38,6 +38,25 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
 
 %prep
 
+%global is_mandriva %(test -f /etc/mandriva-release && echo 1 || echo 0)
+%global is_redhat   %(test -f /etc/redhat-release && echo 1 || echo 0)
+%global is_suse     %(test -f /etc/SuSE-release && echo 1 || echo 0)
+
+# nor are debug-symbols
+%define debug_package %{nil}
+
+%if %{is_mandriva}
+%define _disable_ld_as_needed 1
+%define _disable_ld_no_undefined 1
+# libtool is not used here...
+%define _disable_libtoolize 1
+%define _disable_ld_build_id 1
+%endif
+
+%setup -q -n ncurses-%{version}-%{release}
+
+%build
+%define my_srcdir ..
 %define CFG_OPTS \\\
        --target %{_target_platform} \\\
        --prefix=%{_prefix} \\\
@@ -83,24 +102,23 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
        --without-debug \\\
        --without-normal
 
-%define debug_package %{nil}
-%setup -q -n ncurses-%{version}-%{release}
-
-%build
+%global _configure ../configure
 
 mkdir BUILD-ncurses6
 pushd BUILD-ncurses6
 CFLAGS="%{CC_NORMAL}" \
-RPATH_LIST=../lib:%{_prefix}/lib \
-../configure %{CFG_OPTS}
+RPATH_LIST=../lib:%{_libdir} \
+CONFIGURE_TOP=%{my_srcdir} \
+%configure %{CFG_OPTS}
 make
 popd
 
 mkdir BUILD-ncursest6
 pushd BUILD-ncursest6
 CFLAGS="%{CC_NORMAL}" \
-RPATH_LIST=../lib:%{_prefix}/lib \
-../configure %{CFG_OPTS} \
+RPATH_LIST=../lib:%{_libdir} \
+CONFIGURE_TOP=%{my_srcdir} \
+%configure %{CFG_OPTS} \
        --enable-interop \
        --enable-sp-funcs \
        --program-suffix=t%{MY_ABI} \
@@ -131,15 +149,39 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/*
 %{_includedir}/*
 %{_libdir}/*
+%exclude %{_bindir}/tict6
+%exclude %{_bindir}/toet6
+%exclude %{_bindir}/tabst6
+%exclude %{_bindir}/resett6
+%exclude %{_bindir}/???*tt6
+%exclude %{_bindir}/?????*t6
+%exclude %{_bindir}/*tw6*
+%exclude %dir %{_includedir}/*tw6*
+%exclude %{_includedir}/*tw6*/*
+%exclude %{_libdir}/*tw6*
+%exclude %{_libdir}/pkgconfig/*tw6*
 
 %files -n ncursest6
 %defattr(-,root,root,-)
-%{_bindir}/*
-%{_includedir}/*
-%{_libdir}/*
+%{_bindir}/tict6
+%{_bindir}/toet6
+%{_bindir}/tabst6
+%{_bindir}/???*tt6
+%{_bindir}/?????*t6
+%{_bindir}/*tw6*
+%{_includedir}/*tw6*
+%{_libdir}/*tw6*
+%{_libdir}/pkgconfig/*tw6*
 
 %changelog
 
+* Sat Jun 02 2018 Thomas E. Dickey
+- build-fix for Mageia
+
+* Sat May 26 2018 Thomas E. Dickey
+- use predefined configure-macro
+- separate ncurses6/ncursest6 packages
+
 * Sat Feb 10 2018 Thomas E. Dickey
 - add ncursest6 package
 - add several development features