]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/ncursest.spec
ncurses 6.2 - patch 20210417
[ncurses.git] / package / ncursest.spec
index ee17e3b5b8711404f7a3964e360e0b2c931a631b..4eee924c4501029561a7f4e24a6343fdfa1bb7ae 100644 (file)
@@ -1,15 +1,12 @@
 Summary: Curses library with POSIX thread support.
 Name: ncursest6
-Version: 6.1
-Release: 20191207
+Version: 6.2
+Release: 20210417
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
 # URL: https://invisible-island.net/ncurses/
 
-%define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
-%define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
-
 %global MY_ABI 6
 
 # save value before redefining
@@ -30,11 +27,17 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
 %prep
 
 %global is_mandriva %(test -f /etc/mandriva-release && echo 1 || echo 0)
+%global is_fedora   %(test -f /usr/bin/dnf && echo 1 || echo 0)
+%global is_centos   %(test -f /etc/centos-release && echo 1 || echo 0)
 %global is_redhat   %(test -f /etc/redhat-release && echo 1 || echo 0)
+%global is_scilinux %(test -f /etc/sl-release && echo 1 || echo 0)
 %global is_suse     %(test -f /etc/SuSE-release && echo 1 || echo 0)
 
-# nor are debug-symbols
+%if %{is_redhat}
+# generate debug/debug-source packages.
+%else
 %define debug_package %{nil}
+%endif
 
 %if %{is_mandriva}
 %define _disable_ld_as_needed 1
@@ -44,7 +47,7 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
 %define _disable_ld_build_id 1
 %endif
 
-%if %{is_redhat}
+%if %{is_fedora} || %{is_scilinux} || %{is_centos}
 # workaround for toolset breakage in Fedora 28
 %define _test_relink --enable-relink
 %else
@@ -54,7 +57,6 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
 %setup -q -n ncurses-%{version}-%{release}
 
 %build
-%define my_srcdir ..
 %define CFG_OPTS \\\
        --target %{_target_platform} \\\
        --prefix=%{_prefix} \\\
@@ -101,8 +103,6 @@ This package is used for testing ABI %{MY_ABI} with POSIX threads.
        --without-debug \\\
        --without-normal
 
-CFLAGS="%{CC_NORMAL}" \
-RPATH_LIST=../lib:%{_libdir} \
 %configure %{CFG_OPTS} \
        --enable-interop \
        --enable-sp-funcs \
@@ -117,6 +117,15 @@ make install.libs install.progs
 rm -f test/ncurses
 ( cd test && make ncurses LOCAL_LIBDIR=%{_libdir} && mv ncurses $RPM_BUILD_ROOT/%{_bindir}/ncursest%{MY_ABI} )
 
+%if %{is_mandriva}
+# check this first because Mageia has the /etc/redhat-release file...
+%else
+%if %{is_fedora}
+%ldconfig_scriptlets libs
+%ldconfig_scriptlets c++-libs
+%endif
+%endif
+
 %clean
 if rm -rf $RPM_BUILD_ROOT; then
   echo OK
@@ -133,6 +142,11 @@ exit 0
 
 %changelog
 
+* Tue Dec 24 2019 Thomas Dickey
+- drop custom CC_NORMAL warning flags because setting CFLAGS interferes with
+  matching Fedora's PIE/PIC configuration.  Also, generate debug/debug-source
+  packages.
+
 * Sat Nov 16 2019 Thomas Dickey
 - modify clean-rule to work around Fedora NFS bugs.