]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20130427
[ncurses.git] / test / configure.in
index 13e4eded522e02788a568c77b7c52c36879a269c..5b7c28303f88925ba228b6661dbd4e44c3b29a22 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2011,2012 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2012,2013 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.108 2012/10/06 22:33:49 tom Exp $
+dnl $Id: configure.in,v 1.111 2013/04/27 19:45:29 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -138,9 +138,12 @@ pdcurses) #(vi
        ;;
 *)
        # look for curses-related libraries
-       AC_CHECK_LIB(panel$cf_cv_libtype,new_panel)
-       AC_CHECK_LIB(menu$cf_cv_libtype,menu_driver)
-       AC_CHECK_LIB(form$cf_cv_libtype,form_driver)
+       : ${cf_panel_lib:=panel}
+       : ${cf_menu_lib:=menu}
+       : ${cf_form_lib:=form}
+       AC_CHECK_LIB($cf_panel_lib$cf_cv_libtype,new_panel)
+       AC_CHECK_LIB($cf_menu_lib$cf_cv_libtype,menu_driver)
+       AC_CHECK_LIB($cf_form_lib$cf_cv_libtype,form_driver)
 
        # look for curses-related headers
        AC_CHECK_HEADERS( \
@@ -154,8 +157,6 @@ pdcurses) #(vi
        ;;
 esac
 
-AC_TYPE_SIGNAL
-
 AC_STDC_HEADERS
 AC_HEADER_TIME
 AC_CHECK_HEADERS( \
@@ -174,7 +175,6 @@ CF_GETOPT_HEADER
 
 AC_CHECK_FUNCS( \
 gettimeofday \
-strdup \
 )
 
 if test "$cf_enable_widec" = yes; then