]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 6.0 - patch 20180106
[ncurses.git] / test / configure.in
index 4f2bd8ad4b819216af0cbc8c2c241b9abf6edca9..6d9183b8a3b640486707857d65608fc7c1c15d27 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2016,2017 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2017,2018 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996-on
 dnl
-dnl $Id: configure.in,v 1.135 2017/08/20 16:38:29 tom Exp $
+dnl $Id: configure.in,v 1.148 2018/01/02 23:39:26 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -37,8 +37,8 @@ dnl If you're configuring ncurses, you shouldn't need to use this script.
 dnl It's only for testing purposes.
 dnl
 dnl For additional information, see
-dnl            http://invisible-island.net/autoconf/
-dnl            http://invisible-island.net/ncurses/ncurses-examples.html
+dnl            https://invisible-island.net/autoconf/
+dnl            https://invisible-island.net/ncurses/ncurses-examples.html
 dnl ---------------------------------------------------------------------------
 AC_PREREQ(2.52.20170501)
 AC_INIT(ncurses.c)
@@ -52,6 +52,7 @@ AC_ARG_PROGRAM
 
 AC_PROG_MAKE_SET
 CF_PROG_CC
+AC_C_INLINE
 AC_PROG_CPP
 AC_PROG_AWK
 CF_PROG_INSTALL
@@ -136,6 +137,8 @@ case $cf_cv_screen in
        ;;
 esac
 
+CF_WITH_X11_RGB
+
 dnl If we've not specified a library, assume we're using sysvr4 libraries
 dnl installed conventionally (e.g., SunOS 5.x - solaris).
 
@@ -178,7 +181,7 @@ CF_ARG_DISABLE(panel,
 AC_MSG_RESULT($cf_enable_panel)
 if test $cf_enable_panel = yes
 then
-       CF_CHECK_CURSES_LIB(panel,$cf_cv_libtype,new_panel)
+       CF_CHECK_CURSES_LIB(panel,$cf_cv_libtype,new_panel,0)
        cf_curses_headers="$cf_curses_headers panel.h"
 fi
 
@@ -198,7 +201,7 @@ then
                CF_NETBSD_MENU_H
                ;;
        esac
-       CF_CHECK_CURSES_LIB(menu,$cf_cv_libtype,menu_driver)
+       CF_CHECK_CURSES_LIB(menu,$cf_cv_libtype,menu_driver,[0,0])
        cf_curses_headers="$cf_curses_headers menu.h"
 fi
 
@@ -218,7 +221,7 @@ then
                CF_NETBSD_FORM_H
                ;;
        esac
-       CF_CHECK_CURSES_LIB(form,$cf_cv_libtype,form_driver)
+       CF_CHECK_CURSES_LIB(form,$cf_cv_libtype,form_driver,[0,0])
        cf_curses_headers="$cf_curses_headers form.h"
 fi
 
@@ -249,6 +252,17 @@ tdestroy \
 tsearch \
 )
 
+# use a compile-check to work with ncurses*-config and subdirectory includes
+AC_CACHE_CHECK(if we can use termcap.h,cf_cv_have_termcap_h,[
+       AC_TRY_COMPILE([
+#include <curses.h>
+#include <termcap.h>
+],
+       [return 0;],
+       [cf_cv_have_termcap_h=yes],
+       [cf_cv_have_termcap_h=no])])
+test "x$cf_cv_have_termcap_h" = xyes && AC_DEFINE(HAVE_TERMCAP_H)
+
 if test "x$ac_cv_func_getopt" = xno; then
        AC_MSG_ERROR(getopt is required for building programs)
 fi
@@ -272,6 +286,9 @@ assume_default_colors \
 chgat \
 color_content \
 color_set \
+copywin \
+delscreen \
+dupwin \
 filter \
 getbegx \
 getcurx \
@@ -279,11 +296,16 @@ getmaxx \
 getnstr \
 getparx \
 getwin \
+halfdelay \
 init_extended_color \
+mvderwin \
 mvvline \
+mvwin \
 mvwvline \
 napms \
+newpad \
 putwin \
+reset_color_pairs \
 resize_term \
 resizeterm \
 restartterm \
@@ -308,6 +330,7 @@ vidputs \
 vsscanf \
 vw_printw \
 wchgat \
+winsdelln \
 winsstr \
 wresize \
 wsyncdown \
@@ -418,15 +441,16 @@ if test "$cf_enable_widec" = yes; then
        fi
 fi
 
-CF_CURSES_CHECK_DATA(curscr)
-CF_CURSES_CHECK_DATA(ospeed)
-CF_CURSES_CHECK_DATA(boolnames)
-CF_CURSES_CHECK_DATA(boolfnames)
-CF_CURSES_CHECK_DATA(ttytype)
+CF_CURSES_CHECK_DATA(\
+curscr \
+ospeed \
+boolnames \
+boolfnames \
+ttytype)
 
 dnl ---------------------------------------------------------------------------
 CF_HELP_MESSAGE(Testing/development Options:)
-CF_ENABLE_WARNINGS
+CF_ENABLE_WARNINGS(Wno-unknown-pragmas)
 CF_DISABLE_LEAKS
 CF_DISABLE_RPATH_HACK
 
@@ -453,7 +477,7 @@ do
        \$(srcdir)/test.priv.h \\
        ncurses_cfg.h
        $SHOW_CC
-       $ECHO_CC\$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
+       $ECHO_CC\$(CC) -c \$(CFLAGS_DEFAULT) -DMODULE_NAME="$N" \$(srcdir)/$N.c
 TEST_EOF
 done