]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20140906
[ncurses.git] / test / configure.in
index 5b7c28303f88925ba228b6661dbd4e44c3b29a22..97bcb1d7a3840affa8c75c48a43995971b4a3181 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2012,2013 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2013,2014 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.111 2013/04/27 19:45:29 tom Exp $
+dnl $Id: configure.in,v 1.116 2014/09/05 08:43:30 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -56,7 +56,7 @@ CF_PROG_INSTALL
 CF_PROG_LINT
 CF_MAKE_TAGS
 
-CF_MATH_LIB(MATH_LIB,sin(x))
+CF_MATH_LIB(MATH_LIB,pow(sin(x),x))
 AC_SUBST(MATH_LIB)
 
 dnl Things that we don't need (or must override) if we're not building ncurses
@@ -86,6 +86,7 @@ TINFO_LDFLAGS=''                              AC_SUBST(TINFO_LDFLAGS)
 TINFO_LIBS='$(LIBS_CURSES)'            AC_SUBST(TINFO_LIBS)
 cf_cv_abi_version=""                   AC_SUBST(cf_cv_abi_version)
 cf_cv_rel_version=""                   AC_SUBST(cf_cv_rel_version)
+includesubdir=""                               AC_SUBST(includesubdir)
 
 cf_cv_screen=curses
 cf_cv_libtype=
@@ -218,8 +219,12 @@ tigetnum \
 tigetstr \
 typeahead \
 use_default_colors \
+use_env \
+use_extended_names \
 use_screen \
 use_window \
+vid_puts \
+vidputs \
 vsscanf \
 vw_printw \
 wchgat \