]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20131019
[ncurses.git] / test / configure.in
index dd601cd21e688187a888067a199fb59767a78b25..c9938372e95946259f2b267d96601daa36438644 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2010,2011 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2012,2013 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.93 2011/04/09 20:11:47 tom Exp $
+dnl $Id: configure.in,v 1.113 2013/10/19 21:03:17 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -38,7 +38,7 @@ dnl It's only for testing purposes.
 dnl
 dnl See http://invisible-island.net/autoconf/ for additional information.
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.13.20020210)
+AC_PREREQ(2.52.20030208)
 AC_INIT(ncurses.c)
 AC_CONFIG_HEADER(ncurses_cfg.h:ncurses_tst.hin)
 
@@ -49,17 +49,18 @@ CF_CHECK_CACHE
 AC_ARG_PROGRAM
 
 AC_PROG_MAKE_SET
-AC_PROG_CC
+CF_PROG_CC
 AC_PROG_CPP
 AC_PROG_AWK
 CF_PROG_INSTALL
 CF_PROG_LINT
 CF_MAKE_TAGS
 
-CF_MATH_LIB(MATH_LIB,sin(x))
+CF_MATH_LIB(MATH_LIB,pow(sin(x),x))
 AC_SUBST(MATH_LIB)
 
 dnl Things that we don't need (or must override) if we're not building ncurses
+CF_TOP_BUILDDIR
 CC_G_OPT="-g"                                  AC_SUBST(CC_G_OPT)
 CC_SHARED_OPTS=unknown                 AC_SUBST(CC_SHARED_OPTS)
 CPPFLAGS="$CPPFLAGS"                   AC_SUBST(CPPFLAGS)
@@ -81,9 +82,11 @@ PTHREAD="-lm"                                        AC_SUBST(PTHREAD)
 TEST_ARGS=""                                   AC_SUBST(TEST_ARGS)
 TEST_DEPS=""                                   AC_SUBST(TEST_DEPS)
 TEST_LIBS=""                                   AC_SUBST(TEST_LIBS)
-TINFO_ARGS='$(LIBS_CURSES)'            AC_SUBST(TINFO_ARGS)
+TINFO_LDFLAGS=''                               AC_SUBST(TINFO_LDFLAGS)
+TINFO_LIBS='$(LIBS_CURSES)'            AC_SUBST(TINFO_LIBS)
 cf_cv_abi_version=""                   AC_SUBST(cf_cv_abi_version)
 cf_cv_rel_version=""                   AC_SUBST(cf_cv_rel_version)
+includesubdir=""                               AC_SUBST(includesubdir)
 
 cf_cv_screen=curses
 cf_cv_libtype=
@@ -91,70 +94,38 @@ cf_cv_libtype=
 AC_EXEEXT
 AC_OBJEXT
 
-CF_ANSI_CC_REQD
 CF_GCC_ATTRIBUTES
 CF_XOPEN_SOURCE
-AC_C_CONST
 CF_SIG_ATOMIC_T
 
+dnl ---------------------------------------------------------------------------
+CF_HELP_MESSAGE(General Options:)
+CF_PKG_CONFIG
 CF_DISABLE_ECHO
-CF_ENABLE_WARNINGS
-
-CF_DISABLE_LEAKS
 
 dnl ---------------------------------------------------------------------------
+CF_HELP_MESSAGE(Curses Version-dependent Options:)
+CF_NCURSES_WRAP_PREFIX
+
 AC_MSG_CHECKING(if you want to check for wide-character functions)
 CF_ARG_DISABLE(widec,
-       [--disable-widec           disable checks for wide-character functions],
+       [  --disable-widec         disable checks for wide-character functions],
        cf_enable_widec=no,
        cf_enable_widec=yes,
        yes)
 AC_MSG_RESULT($cf_enable_widec)
 
-CF_WITH_CURSES_DIR
-
 dnl ---------------------------------------------------------------------------
-dnl NcursesW, installed in conventional location
-AC_MSG_CHECKING(for specified curses library type)
-AC_ARG_WITH(ncursesw,
-       [  --with-ncursesw         use wide ncurses-libraries (installed)],
-       [cf_cv_screen=ncursesw],[
-
-dnl Ncurses, installed in conventional location
-AC_ARG_WITH(ncurses,
-       [  --with-ncurses          use ncurses-libraries (installed)],
-       [cf_cv_screen=ncurses],[
-
-AC_ARG_WITH(pdcurses,
-       [  --with-pdcurses         compile/link with pdcurses X11 library],
-       [cf_cv_screen=pdcurses],[
-
-AC_ARG_WITH(curses-colr,
-       [  --with-curses-colr      compile/link with HPUX 10.x color-curses],
-       [cf_cv_screen=curses_colr],[
-
-AC_ARG_WITH(curses-5lib,
-       [  --with-curses-5lib      compile/link with SunOS 5lib curses],
-       [cf_cv_screen=curses_5lib])])])])])
-
-AC_MSG_RESULT($cf_cv_screen)
+CF_HELP_MESSAGE(Curses Version-dependent Options:)
+CF_WITH_NCURSES_ETC
 
 case $cf_cv_screen in
 curses|curses_*)
-       CF_CURSES_CONFIG
        CF_NETBSD_FORM_H
        CF_NETBSD_MENU_H
        ;;
-ncurses)
-       CF_NCURSES_CONFIG
-       ;;
 ncursesw)
        cf_cv_libtype=w
-       CF_UTF8_LIB
-       CF_NCURSES_CONFIG(ncursesw)
-       ;;
-pdcurses) #(vi
-       CF_PDCURSES_X11
        ;;
 esac
 
@@ -168,9 +139,12 @@ pdcurses) #(vi
        ;;
 *)
        # look for curses-related libraries
-       AC_CHECK_LIB(panel$cf_cv_libtype,new_panel)
-       AC_CHECK_LIB(menu$cf_cv_libtype,menu_driver)
-       AC_CHECK_LIB(form$cf_cv_libtype,form_driver)
+       : ${cf_panel_lib:=panel}
+       : ${cf_menu_lib:=menu}
+       : ${cf_form_lib:=form}
+       AC_CHECK_LIB($cf_panel_lib$cf_cv_libtype,new_panel)
+       AC_CHECK_LIB($cf_menu_lib$cf_cv_libtype,menu_driver)
+       AC_CHECK_LIB($cf_form_lib$cf_cv_libtype,form_driver)
 
        # look for curses-related headers
        AC_CHECK_HEADERS( \
@@ -184,8 +158,6 @@ pdcurses) #(vi
        ;;
 esac
 
-AC_TYPE_SIGNAL
-
 AC_STDC_HEADERS
 AC_HEADER_TIME
 AC_CHECK_HEADERS( \
@@ -200,9 +172,10 @@ termios.h \
 unistd.h \
 )
 
+CF_GETOPT_HEADER
+
 AC_CHECK_FUNCS( \
 gettimeofday \
-strdup \
 )
 
 if test "$cf_enable_widec" = yes; then
@@ -219,6 +192,7 @@ wcstombs \
 fi
 
 CF_CURSES_FUNCS( \
+assume_default_colors \
 chgat \
 color_set \
 filter \
@@ -245,18 +219,46 @@ tigetnum \
 tigetstr \
 typeahead \
 use_default_colors \
-vw_printw \
+use_screen \
+use_window \
 vsscanf \
+vw_printw \
 wchgat \
 winsstr \
 wresize \
 wsyncdown \
 )
 
+CF_TPUTS_PROTO
 CF_NCURSES_EXT_FUNCS
 
 if test "$cf_enable_widec" = yes
 then
+       # workaround for systems with ncurses before 20111029, due to change of
+       # feature test macro from _XPG5 to _XOPEN_SOURCE
+       if test -n "$cf_cv_ncurses_version" && test "x$cf_cv_ncurses_version" != xno
+       then
+               cf_define_xpg5=no
+               AC_MSG_CHECKING(if _XPG5 should be defined to enable wide-characters)
+
+               AC_TRY_COMPILE([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+                       [int x = _XPG5],,
+                       [cf_save_cppflags="$CPPFLAGS"
+                        CPPFLAGS="$CPPFLAGS -D_XPG5"
+                        AC_TRY_COMPILE([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+                               [int x = _XPG5],
+                               [cf_define_xpg5=yes])
+                        CPPFLAGS="$cf_save_cppflags"])
+               AC_MSG_RESULT($cf_define_xpg5)
+
+               if test "$cf_define_xpg5" = yes
+               then
+                       CPPFLAGS="$CPPFLAGS -D_XPG5"
+               fi
+       fi
+
        AC_CACHE_CHECK(for wide-character functions,cf_cv_widechar_funcs,[
        AC_TRY_LINK([
 #include <${cf_cv_ncurses_header:-curses.h}>],
@@ -269,7 +271,7 @@ then
                [cf_cv_widechar_funcs=no])
        ])
        if test "$cf_cv_widechar_funcs" != no ; then
-               AC_DEFINE(USE_WIDEC_SUPPORT,1)
+               AC_DEFINE(USE_WIDEC_SUPPORT,1,[Define to 1 to enable wide-character support in (n)curses])
        else
                AC_DEFINE(USE_WIDEC_SUPPORT,0)
        fi
@@ -279,8 +281,8 @@ fi
 
 CF_SYS_TIME_SELECT
 CF_FUNC_CURSES_VERSION
-CF_CURSES_ACS_MAP
 
+CF_CURSES_ACS_MAP
 if test "$cf_enable_widec" = yes; then
        CF_CURSES_WACS_MAP
        CF_CURSES_WACS_SYMBOLS
@@ -309,6 +311,12 @@ fi
 CF_CURSES_CHECK_DATA(boolnames)
 CF_CURSES_CHECK_DATA(boolfnames)
 
+dnl ---------------------------------------------------------------------------
+CF_HELP_MESSAGE(Testing/development Options:)
+CF_ENABLE_WARNINGS
+CF_DISABLE_LEAKS
+CF_DISABLE_RPATH_HACK
+
 TEST_ARGS="$LIBS"
 LIBS=
 
@@ -331,7 +339,8 @@ do
 \$(MODEL)/$N.o : \$(srcdir)/$N.c \\
        \$(srcdir)/test.priv.h \\
        ncurses_cfg.h
-       @echo compiling $N; \$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
+       $SHOW_CC
+       $ECHO_CC\$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
 TEST_EOF
 done
 
@@ -346,5 +355,7 @@ TEST_EOF
 fi
 ],[
 AWK="$AWK"
+ECHO_CC="$ECHO_CC"
 ECHO_LD="$ECHO_LD"
+SHOW_CC="$SHOW_LD"
 ],cat)