]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/debian/rules
ncurses 6.0 - patch 20170722
[ncurses.git] / test / package / debian / rules
index bed7a82a76cc7c8f090efe83436be64857d04476..1598d6fe896b306138bfbb253a2ef33a274a3c79 100755 (executable)
@@ -18,7 +18,9 @@ PACKAGES.arch  = $(NCURSES_PKG) $(NCURSEST_PKG)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS =
+CFLAGS   = $(shell dpkg-buildflags --get CFLAGS)
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
+LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -O0
@@ -32,7 +34,9 @@ endif
 verbose = # -v
 
 configure = \
-       CFLAGS="$(CFLAGS)" ../../configure \
+       CFLAGS="$(CFLAGS)" \
+       CPPFLAGS="$(CPPFLAGS)" \
+       LDFLAGS="$(LDFLAGS)" ../../configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
                --prefix=/usr \