]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/ncurses-examples.spec
ncurses 6.0 - patch 20171216
[ncurses.git] / test / package / ncurses-examples.spec
index ad79e5a2218abb010f1f30d13c9dd4099de6ee59..821268437af971f1b998c488c72cd0d1af71e4f6 100644 (file)
@@ -2,13 +2,13 @@ Summary: ncurses-examples - example/test programs from ncurses
 %define AppProgram ncurses-examples
 %define AppVersion MAJOR.MINOR
 %define AppRelease YYYYMMDD
-# $Id: ncurses-examples.spec,v 1.2 2011/03/25 17:46:44 tom Exp $
+# $Id: ncurses-examples.spec,v 1.9 2017/12/17 00:12:42 tom Exp $
 Name: %{AppProgram}
 Version: %{AppVersion}
 Release: %{AppRelease}
 License: MIT
 Group: Applications/Development
-URL: ftp://invisible-island.net/%{AppProgram}
+URL: ftp://ftp.invisible-island.net/%{AppProgram}
 Source0: %{AppProgram}-%{AppRelease}.tgz
 Packager: Thomas Dickey <dickey@invisible-island.net>
 
@@ -22,15 +22,18 @@ packages.
 
 %setup -q -n %{AppProgram}-%{AppRelease}
 
+%define debug_package %{nil}
+
 %build
 
 INSTALL_PROGRAM='${INSTALL}' \
-       ./configure \
-               --target %{_target_platform} \
-               --prefix=%{_prefix} \
-               --bindir=%{_bindir}/%{AppProgram} \
-               --with-ncursesw \
-               --disable-rpath-hack
+%configure \
+       --target %{_target_platform} \
+       --prefix=%{_prefix} \
+       --bindir=%{_bindir}/%{AppProgram} \
+       --datadir=%{_datadir}/%{AppProgram} \
+       --with-screen=ncursesw6 \
+       --disable-rpath-hack
 
 make
 
@@ -47,9 +50,15 @@ strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}/*
 %files
 %defattr(-,root,root)
 %{_bindir}/%{AppProgram}/*
+%{_datadir}/%{AppProgram}/*
 
 %changelog
 # each patch should add its ChangeLog entries here
 
-* Fri Mar 25 2010 Thomas Dickey
+* Sat Nov 11 2017 Thomas Dickey
+- add example data-files
+- use rpm built-in "configure"
+- suppress debug-package
+
+* Thu Mar 25 2010 Thomas Dickey
 - initial version