]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/package/ncurses-examples.spec
ncurses 6.1 - patch 20190126
[ncurses.git] / test / package / ncurses-examples.spec
index 8ca1c1e92056bd68c30463c766276eee788d498c..d912ea8b948fcea3ce1f2f9857c6289c14b20103 100644 (file)
@@ -1,8 +1,9 @@
-Summary: ncurses-examples - example/test programs from ncurses
-%define AppProgram ncurses-examples
-%define AppVersion MAJOR.MINOR
-%define AppRelease YYYYMMDD
-# $Id: ncurses-examples.spec,v 1.11 2018/01/15 16:14:16 tom Exp $
+Summary: example/test programs from ncurses
+%global AppProgram ncurses-examples
+%global AltProgram ncursest-examples
+%global AppVersion MAJOR.MINOR
+%global AppRelease YYYYMMDD
+# $Id: ncurses-examples.spec,v 1.13 2019/01/27 00:22:06 tom Exp $
 Name: %{AppProgram}
 Version: %{AppVersion}
 Release: %{AppRelease}
@@ -16,8 +17,20 @@ Packager: Thomas Dickey <dickey@invisible-island.net>
 These are the example/test programs from the ncurses MAJOR.MINOR distribution,
 for patch-date YYYYMMDD.
 
-This package installs in "bin/ncurses-examples" to avoid conflict with other
+This package installs in "bin/%{AppProgram}" to avoid conflict with other
 packages.
+
+%package -n %{AltProgram}
+Summary:  examples/test programs from ncurses with POSIX thread support
+
+%description -n %{AltProgram}
+These are the example/test programs from the ncurses MAJOR.MINOR distribution,
+for patch-date YYYYMMDD, using the "ncurseswt" library to demonstrate the
+use of POSIX threads, e.g., in ditto, rain, and worm.
+
+This package installs in "bin/%{AltProgram}" to avoid conflict with other
+packages.
+
 %prep
 
 %setup -q -n %{AppProgram}-%{AppRelease}
@@ -26,8 +39,14 @@ packages.
 
 %build
 
+%global _configure ../configure
+%define my_srcdir ..
+
+mkdir BUILD-%{AppProgram}
+pushd BUILD-%{AppProgram}
 INSTALL_PROGRAM='${INSTALL}' \
 NCURSES_CONFIG_SUFFIX=dev \
+CONFIGURE_TOP=%{my_srcdir} \
 %configure \
        --target %{_target_platform} \
        --prefix=%{_prefix} \
@@ -37,20 +56,48 @@ NCURSES_CONFIG_SUFFIX=dev \
        --disable-rpath-hack
 
 make
+popd
+
+mkdir BUILD-%{AltProgram}
+pushd BUILD-%{AltProgram}
+INSTALL_PROGRAM='${INSTALL}' \
+NCURSES_CONFIG_SUFFIX=dev \
+CONFIGURE_TOP=%{my_srcdir} \
+%configure \
+       --target %{_target_platform} \
+       --prefix=%{_prefix} \
+       --bindir=%{_bindir}/%{AltProgram} \
+       --datadir=%{_datadir}/%{AltProgram} \
+       --with-screen=ncursestw6 \
+       --disable-rpath-hack
+
+make
+popd
 
 %install
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
-make install               DESTDIR=$RPM_BUILD_ROOT
+pushd BUILD-%{AppProgram}
+make install DESTDIR=$RPM_BUILD_ROOT
+popd
+
+pushd BUILD-%{AltProgram}
+make install DESTDIR=$RPM_BUILD_ROOT
+popd
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
-%files
+%files -n %{AppProgram}
 %defattr(-,root,root)
 %{_bindir}/%{AppProgram}/*
 %{_datadir}/%{AppProgram}/*
 
+%files -n %{AltProgram}
+%defattr(-,root,root)
+%{_bindir}/%{AltProgram}/*
+%{_datadir}/%{AltProgram}/*
+
 %changelog
 # each patch should add its ChangeLog entries here