ncurses 6.0 - patch 20150613
authorThomas E. Dickey <dickey@invisible-island.net>
Sun, 14 Jun 2015 01:15:46 +0000 (01:15 +0000)
committerThomas E. Dickey <dickey@invisible-island.net>
Sun, 14 Jun 2015 01:15:46 +0000 (01:15 +0000)
commit4ec5af5be84fa04621664e4f6f1235c12dc1ce88
tree30b9d8a30498fa3120bec87d09ef8541fd5f03e0
parentdb5f7f4f146a91ba8ec7f1df8e9d7f9d2d7c74fd
ncurses 6.0 - patch 20150613

+ fix overflow warning for OSX with lib_baudrate.c (cf: 20010630).
+ modify script used to generate map/sym files to mark 5.9.20150530 as
  the last "5.9" version, and regenerated the files.  That makes the
  files not use ".current" for the post-5.9 symbols.  This also
  corrects the label for _nc_sigprocmask used in when weak symbols are
  configured for the ncursest/ncursestw libraries (prompted by
  discussion with Sven Joachim).
+ fix typo in NEWS (report by Sven Joachim).
  "--with-abi-version=5" option.
18 files changed:
NEWS
VERSION
dist.mk
ncurses/tinfo/lib_baudrate.c
package/debian-mingw/changelog
package/debian-mingw64/changelog
package/debian/changelog
package/mingw-ncurses.nsi
package/mingw-ncurses.spec
package/ncurses.map
package/ncurses.spec
package/ncurses.sym
package/ncursest.map
package/ncursest.sym
package/ncursestw.map
package/ncursestw.sym
package/ncursesw.map
package/ncursesw.sym