From e2c422e26543d96636d8bde422550ea9c7005e9c Mon Sep 17 00:00:00 2001 From: "Thomas E. Dickey" Date: Sun, 19 Nov 2023 01:11:57 +0000 Subject: [PATCH] ncurses 6.4 - patch 20231118 + improve description of length-parameter and error-returns in several manpages: curs_addchstr.3x, curs_addstr.3x, curs_addwstr.3x, curs_in_wch.3x, curs_in_wchstr.3x, curs_inchstr.3x, curs_ins_wstr.3x, curs_insstr.3x, curs_instr.3x, curs_inwstr.3x + amend parameter check for entire string versus specific length in winsnstr() and wins_nwstr() to match Solaris. + make similar correction to wins_nwstr(). + correct loop termination condition in waddnstr() and waddnwstr() (Debian #1055882, cf: 20201205). --- NEWS | 13 ++++- VERSION | 2 +- dist.mk | 4 +- doc/html/man/curs_add_wchstr.3x.html | 45 ++++++++++-------- doc/html/man/curs_addchstr.3x.html | 37 ++++++++------- doc/html/man/curs_addstr.3x.html | 21 +++----- doc/html/man/curs_addwstr.3x.html | 11 +++-- doc/html/man/curs_in_wch.3x.html | 11 +++-- doc/html/man/curs_in_wchstr.3x.html | 43 +++++++++++------ doc/html/man/curs_inchstr.3x.html | 56 ++++++++++++---------- doc/html/man/curs_ins_wstr.3x.html | 71 +++++++++++++++++----------- doc/html/man/curs_insstr.3x.html | 66 +++++++++++++++----------- doc/html/man/curs_instr.3x.html | 39 +++++++++------ doc/html/man/curs_inwstr.3x.html | 48 ++++++++++++------- doc/html/man/ncurses.3x.html | 2 +- doc/html/man/terminfo.5.html | 2 +- man/curs_add_wchstr.3x | 22 +++++---- man/curs_addchstr.3x | 21 ++++---- man/curs_addstr.3x | 21 +++----- man/curs_addwstr.3x | 9 ++-- man/curs_in_wch.3x | 9 ++-- man/curs_in_wchstr.3x | 59 +++++++++++++---------- man/curs_inchstr.3x | 45 +++++++++++++----- man/curs_ins_wstr.3x | 61 +++++++++++++++--------- man/curs_insstr.3x | 52 +++++++++++++------- man/curs_instr.3x | 47 +++++++++++++----- man/curs_inwstr.3x | 57 +++++++++++++++++----- man/manhtml.aliases | 5 +- ncurses/base/lib_addstr.c | 26 +++++----- ncurses/base/lib_insnstr.c | 10 ++-- ncurses/widechar/lib_ins_wch.c | 15 ++++-- package/debian-mingw/changelog | 4 +- package/debian-mingw64/changelog | 4 +- package/debian/changelog | 4 +- package/mingw-ncurses.nsi | 4 +- package/mingw-ncurses.spec | 2 +- package/ncurses.spec | 2 +- package/ncursest.spec | 2 +- 38 files changed, 581 insertions(+), 371 deletions(-) diff --git a/NEWS b/NEWS index 012df958..c8c40411 100644 --- a/NEWS +++ b/NEWS @@ -26,7 +26,7 @@ -- sale, use or other dealings in this Software without prior written -- -- authorization. -- ------------------------------------------------------------------------------- --- $Id: NEWS,v 1.4031 2023/11/11 23:13:58 tom Exp $ +-- $Id: NEWS,v 1.4033 2023/11/19 00:46:27 tom Exp $ ------------------------------------------------------------------------------- This is a log of changes that ncurses has gone through since Zeyd started @@ -46,6 +46,17 @@ See the AUTHORS file for the corresponding full names. Changes through 1.9.9e did not credit all contributions; it is not possible to add this information. +20231118 + + improve description of length-parameter and error-returns in several + manpages: curs_addchstr.3x, curs_addstr.3x, curs_addwstr.3x, + curs_in_wch.3x, curs_in_wchstr.3x, curs_inchstr.3x, curs_ins_wstr.3x, + curs_insstr.3x, curs_instr.3x, curs_inwstr.3x + + amend parameter check for entire string versus specific length in + winsnstr() and wins_nwstr() to match Solaris. + + make similar correction to wins_nwstr(). + + correct loop termination condition in waddnstr() and waddnwstr() + (Debian #1055882, cf: 20201205). + 20231111 + used "infocmp -u" to help trim redundant capabilities -TD + add limit checks in infocmp needed when processing extended diff --git a/VERSION b/VERSION index 5809d11d..5be4535c 100644 --- a/VERSION +++ b/VERSION @@ -1 +1 @@ -5:0:10 6.4 20231111 +5:0:10 6.4 20231118 diff --git a/dist.mk b/dist.mk index af5ebc7a..d9f52767 100644 --- a/dist.mk +++ b/dist.mk @@ -26,7 +26,7 @@ # use or other dealings in this Software without prior written # # authorization. # ############################################################################## -# $Id: dist.mk,v 1.1576 2023/11/11 10:45:00 tom Exp $ +# $Id: dist.mk,v 1.1577 2023/11/18 10:46:15 tom Exp $ # Makefile for creating ncurses distributions. # # This only needs to be used directly as a makefile by developers, but @@ -38,7 +38,7 @@ SHELL = /bin/sh # These define the major/minor/patch versions of ncurses. NCURSES_MAJOR = 6 NCURSES_MINOR = 4 -NCURSES_PATCH = 20231111 +NCURSES_PATCH = 20231118 # We don't append the patch to the version, since this only applies to releases VERSION = $(NCURSES_MAJOR).$(NCURSES_MINOR) diff --git a/doc/html/man/curs_add_wchstr.3x.html b/doc/html/man/curs_add_wchstr.3x.html index 93978f7d..b26572a4 100644 --- a/doc/html/man/curs_add_wchstr.3x.html +++ b/doc/html/man/curs_add_wchstr.3x.html @@ -27,19 +27,19 @@ * sale, use or other dealings in this Software without prior written * * authorization. * **************************************************************************** - * @Id: curs_add_wchstr.3x,v 1.28 2023/10/07 21:19:07 tom Exp @ + * @Id: curs_add_wchstr.3x,v 1.30 2023/11/18 21:18:55 tom Exp @ --> -curs_add_wchstr 3x 2023-10-07 ncurses 6.4 Library calls +curs_add_wchstr 3x 2023-11-18 ncurses 6.4 Library calls -

curs_add_wchstr 3x 2023-10-07 ncurses 6.4 Library calls

+

curs_add_wchstr 3x 2023-11-18 ncurses 6.4 Library calls

 curs_add_wchstr(3x)              Library calls             curs_add_wchstr(3x)
 
@@ -69,37 +69,42 @@
 

DESCRIPTION

        These  functions copy the (null-terminated) array of complex characters
        wchstr into the window image structure starting at the  current  cursor
-       position.   The four functions with n as the last argument copy at most
-       n elements, but no more than will fit on the line.  If  n=-1  then  the
-       whole  array  is  copied, to the maximum number of characters that will
-       fit on the line.
+       position.
 
-       The window cursor is not advanced.  These functions  work  faster  than
+       The four functions with n as the last argument copy at most n elements,
+       but no more than will fit on the line.  If n=-1 then the whole array is
+       copied, to the maximum number of characters that will fit on the line.
+
+       The  window  cursor  is  not advanced.  These functions are faster than
        waddnstr.  On the other hand:
 
-       o   they  do  not perform checking (such as for the newline, backspace,
+       o   they do not perform checking (such as for the  newline,  backspace,
            or carriage return characters),
 
        o   they do not advance the current cursor position,
 
        o   they do not expand other control characters to ^-escapes, and
 
-       o   they truncate the string if it crosses  the  right  margin,  rather
+       o   they  truncate  the  string  if it crosses the right margin, rather
            than wrapping it around to the new line.
 
-       These  functions  end  successfully  on encountering a null cchar_t, or
-       when they have filled the current line.  If a complex character  cannot
-       completely  fit  at  the end of the current line, the remaining columns
+       These functions end successfully on encountering  a  null  cchar_t,  or
+       when  they have filled the current line.  If a complex character cannot
+       completely fit at the end of the current line,  the  remaining  columns
        are filled with the background character and rendition.
 
 
 

RETURN VALUE

        All functions return the integer ERR upon failure and OK on success.
 
-       X/Open does not  define  any  error  conditions.   This  implementation
-       returns an error if the window pointer is null.
+       X/Open  does  not  define  any  error  conditions.  This implementation
+       returns an error
+
+       o   if the win parameter is null or
 
-       Functions  with  a  "mv"  prefix  first perform a cursor movement using
+       o   if the wchstr parameter is null.
+
+       Functions with a "mv" prefix first  perform  a  cursor  movement  using
        wmove, and return an error if the position is outside the window, or if
        the window pointer is null.
 
@@ -113,14 +118,12 @@
 
 
 

SEE ALSO

-       curses(3x), curs_addwstr(3x)
-
-       Comparable  functions  in  the  narrow-character  (ncurses) library are
-       described in curs_addchstr(3x).
+       curses(3x),   curs_addch(3x),    curs_addchstr(3x),    curs_addstr(3x),
+       curs_addwstr(3x), curs_add_wch(3x)
 
 
 
-ncurses 6.4                       2023-10-07               curs_add_wchstr(3x)
+ncurses 6.4                       2023-11-18               curs_add_wchstr(3x)