From ebe7300d4d5ea549c342500379498fab4b77ea87 Mon Sep 17 00:00:00 2001 From: "Thomas E. Dickey" Date: Sat, 22 Jun 2024 23:49:00 +0000 Subject: [PATCH] ncurses 6.5 - patch 20240622 + improve test/gdc.c (patch by Branden Robinson). + improve formatting/style of manpages (patches by Branden Robinson). + adjust naming of mingw *-config scripts to match the pkg-config names + widen pattern in pc/*-config scripts to disallow more linker options + add --cflags-only-I and --cflags-only-other options to misc/ncurses-config.in + revert change to CF_BUILD_CC macro (report by Vassili Courzakis, cf: 20240518). --- NEWS | 12 +- VERSION | 2 +- aclocal.m4 | 8 +- announce.html.in | 10 +- configure | 4 +- dist.mk | 4 +- doc/html/man/curs_add_wchstr.3x.html | 18 +- doc/html/man/curs_addch.3x.html | 99 ++--- doc/html/man/curs_addstr.3x.html | 17 +- doc/html/man/curs_beep.3x.html | 10 +- doc/html/man/curs_get_wstr.3x.html | 24 +- doc/html/man/curs_getstr.3x.html | 271 +++++++------ doc/html/man/curs_kernel.3x.html | 67 ++-- doc/html/man/curs_pad.3x.html | 10 +- doc/html/man/curs_slk.3x.html | 8 +- doc/html/man/curs_termcap.3x.html | 8 +- doc/html/man/curs_util.3x.html | 8 +- doc/html/man/curs_variables.3x.html | 8 +- doc/html/man/ncurses.3x.html | 206 +++++----- doc/html/man/tabs.1.html | 12 +- doc/html/man/terminfo.5.html | 2 +- doc/html/man/tput.1.html | 14 +- man/curs_add_wchstr.3x | 25 +- man/curs_addch.3x | 14 +- man/curs_addstr.3x | 19 +- man/curs_beep.3x | 8 +- man/curs_get_wstr.3x | 20 +- man/curs_getstr.3x | 564 ++++++++++++++++++--------- man/curs_kernel.3x | 10 +- man/curs_pad.3x | 56 ++- man/curs_slk.3x | 8 +- man/curs_termcap.3x | 14 +- man/curs_util.3x | 8 +- man/curs_variables.3x | 6 +- man/man_db.renames.in | 4 +- man/manhtml.aliases | 5 +- man/manhtml.externs | 3 +- man/ncurses.3x | 49 ++- man/tabs.1 | 8 +- man/terminfo.tail | 4 +- man/tput.1 | 13 +- misc/gen-pkgconfig.in | 6 +- misc/ncurses-config.in | 107 +++-- package/debian-mingw/changelog | 4 +- package/debian-mingw/rules | 1 + package/debian-mingw64/changelog | 4 +- package/debian-mingw64/rules | 1 + package/debian/changelog | 4 +- package/mingw-ncurses.nsi | 4 +- package/mingw-ncurses.spec | 2 +- package/ncurses.spec | 2 +- package/ncursest.spec | 2 +- test/gdc.6 | 78 ++-- test/gdc.c | 37 +- 54 files changed, 1167 insertions(+), 745 deletions(-) diff --git a/NEWS b/NEWS index bec446a8..29088a35 100644 --- a/NEWS +++ b/NEWS @@ -26,7 +26,7 @@ -- sale, use or other dealings in this Software without prior written -- -- authorization. -- ------------------------------------------------------------------------------- --- $Id: NEWS,v 1.4139 2024/06/15 20:49:04 tom Exp $ +-- $Id: NEWS,v 1.4143 2024/06/22 22:59:44 tom Exp $ ------------------------------------------------------------------------------- This is a log of changes that ncurses has gone through since Zeyd started @@ -46,6 +46,16 @@ See the AUTHORS file for the corresponding full names. Changes through 1.9.9e did not credit all contributions; it is not possible to add this information. +20240622 + + improve test/gdc.c (patch by Branden Robinson). + + improve formatting/style of manpages (patches by Branden Robinson). + + adjust naming of mingw *-config scripts to match the pkg-config names + + widen pattern in pc/*-config scripts to disallow more linker options + + add --cflags-only-I and --cflags-only-other options to + misc/ncurses-config.in + + revert change to CF_BUILD_CC macro (report by Vassili Courzakis, + cf: 20240518). + 20240615 + improve formatting/style of manpages (patches by Branden Robinson). + review/update modules files. diff --git a/VERSION b/VERSION index 416c43d0..e80d9211 100644 --- a/VERSION +++ b/VERSION @@ -1 +1 @@ -5:0:10 6.5 20240615 +5:0:10 6.5 20240622 diff --git a/aclocal.m4 b/aclocal.m4 index 003bb308..8c39fe41 100644 --- a/aclocal.m4 +++ b/aclocal.m4 @@ -29,7 +29,7 @@ dnl*************************************************************************** dnl dnl Author: Thomas E. Dickey 1995-on dnl -dnl $Id: aclocal.m4,v 1.1071 2024/05/18 19:49:14 tom Exp $ +dnl $Id: aclocal.m4,v 1.1073 2024/06/22 19:57:54 tom Exp $ dnl Macros used in NCURSES auto-configuration script. dnl dnl These macros are maintained separately from NCURSES. The copyright on @@ -741,7 +741,7 @@ if test "$cf_cv_type_of_bool" = unknown ; then fi ])dnl dnl --------------------------------------------------------------------------- -dnl CF_BUILD_CC version: 12 updated: 2024/03/17 09:17:26 +dnl CF_BUILD_CC version: 13 updated: 2024/06/22 13:42:22 dnl ----------- dnl If we're cross-compiling, allow the user to override the tools and their dnl options. The configure script is oriented toward identifying the host @@ -841,9 +841,9 @@ else : ${BUILD_CC:='${CC}'} : ${BUILD_CPP:='${CPP}'} : ${BUILD_CFLAGS:='${CFLAGS}'} - : ${BUILD_CPPFLAGS:='ifelse([$1],,'${CPPFLAGS}',[$1])'} + : ${BUILD_CPPFLAGS:='${CPPFLAGS}'} : ${BUILD_LDFLAGS:='${LDFLAGS}'} - : ${BUILD_LIBS:='ifelse([$2],,'${LIBS}',[$2])'} + : ${BUILD_LIBS:='${LIBS}'} : ${BUILD_EXEEXT:='$x'} : ${BUILD_OBJEXT:='o'} fi diff --git a/announce.html.in b/announce.html.in index 9889ef1b..737dff41 100644 --- a/announce.html.in +++ b/announce.html.in @@ -1,5 +1,5 @@ -curs_add_wchstr 3x 2024-05-11 ncurses 6.5 Library calls +curs_add_wchstr 3x 2024-06-22 ncurses 6.5 Library calls -

curs_add_wchstr 3x 2024-05-11 ncurses 6.5 Library calls

+

curs_add_wchstr 3x 2024-06-22 ncurses 6.5 Library calls

 curs_add_wchstr(3x)              Library calls             curs_add_wchstr(3x)
 
@@ -113,6 +113,15 @@
        X/Open Curses, Issue 4 describes these functions.
 
 
+

HISTORY

+       These functions were initially specified by  X/Open  Curses,  Issue  4.
+       The   System V   Interface  Definition,  Version  4  (1995),  specified
+       functions named waddwchstr and waddwchnstr (and  the  usual  variants).
+       These  were  later additions to SVr4.x, not appearing in the first SVr4
+       (1989).  They differed from X/Open's wadd_wchstr  and  wadd_wchnstr  in
+       that they each took an argument of type wchar_t instead of cchar_t.
+
+
 

SEE ALSO

        curs_addchstr(3x) describes comparable functions of the ncurses library
        in its non-wide-character configuration.
@@ -121,7 +130,7 @@
 
 
 
-ncurses 6.5                       2024-05-11               curs_add_wchstr(3x)
+ncurses 6.5                       2024-06-22               curs_add_wchstr(3x)
 
diff --git a/doc/html/man/curs_addch.3x.html b/doc/html/man/curs_addch.3x.html index ac18dbcb..e0499b47 100644 --- a/doc/html/man/curs_addch.3x.html +++ b/doc/html/man/curs_addch.3x.html @@ -28,19 +28,19 @@ * sale, use or other dealings in this Software without prior written * * authorization. * **************************************************************************** - * @Id: curs_addch.3x,v 1.92 2024/06/08 20:51:41 tom Exp @ + * @Id: curs_addch.3x,v 1.94 2024/06/22 21:34:49 tom Exp @ --> -curs_addch 3x 2024-06-08 ncurses 6.5 Library calls +curs_addch 3x 2024-06-22 ncurses 6.5 Library calls -

curs_addch 3x 2024-06-08 ncurses 6.5 Library calls

+

curs_addch 3x 2024-06-22 ncurses 6.5 Library calls

 curs_addch(3x)                   Library calls                  curs_addch(3x)
 
@@ -206,90 +206,93 @@
 
 
 

PORTABILITY

-       X/Open  Curses,  Issue  4  describes  these functions.  It specifies no
+       Applications employing ncurses extensions should condition their use on
+       the visibility of the NCURSES_VERSION preprocessor macro.
+
+       X/Open Curses, Issue 4 describes  these  functions.   It  specifies  no
        error conditions for them.
 
-       SVr4 curses describes a successful return value  only  as  "an  integer
+       SVr4  curses  describes  a  successful return value only as "an integer
        value other than ERR".
 
-       The  defaults specified for forms-drawing characters apply in the POSIX
+       The defaults specified for forms-drawing characters apply in the  POSIX
        locale.
 
 
 

ACS Symbols

-       X/Open Curses states that the  ACS_  definitions  are  char  constants.
+       X/Open  Curses  states  that  the  ACS_ definitions are char constants.
        Some implementations are problematic.
 
-       o   Solaris  curses, for example, defines the ACS symbols as constants;
+       o   Solaris curses, for example, defines the ACS symbols as  constants;
            others define them as elements of an array.
 
-           This implementation uses an array, acs_map,  as  did  SVr4  curses.
+           This  implementation  uses  an  array, acs_map, as did SVr4 curses.
            NetBSD also uses an array, actually named _acs_char, with a #define
            for compatibility.
 
-       o   HP-UX curses equates some of the  ACS_  symbols  to  the  analogous
-           WACS_  symbols  as  if  the  ACS_ symbols were wide characters (see
-           curs_add_wch(3x)).  The  misdefined  symbols  are  the  arrows  and
+       o   HP-UX  curses  equates  some  of  the ACS_ symbols to the analogous
+           WACS_ symbols as if the ACS_  symbols  were  wide  characters  (see
+           curs_add_wch(3x)).   The  misdefined  symbols  are  the  arrows and
            others that are not used for line drawing.
 
-       o   X/Open  Curses  (Issues  2 through 7) has a typographical error for
-           the ACS_LANTERN symbol, equating  its  "VT100+  Character"  to  "I"
-           (capital  I),  while  the  header  files  for SVr4 curses and other
+       o   X/Open Curses (Issues 2 through 7) has a  typographical  error  for
+           the  ACS_LANTERN  symbol,  equating  its  "VT100+ Character" to "I"
+           (capital I), while the header  files  for  SVr4  curses  and  other
            implementations use "i" (small i).
 
-           None of the terminal descriptions on Unix platforms  use  uppercase
-           I,  except  for  Solaris  (in  its  terminfo  entry  for screen(1),
-           apparently based on the X/Open documentation around 1995).  On  the
-           other  hand,  its gs6300 (AT&T PC6300 with EMOTS Terminal Emulator)
+           None  of  the terminal descriptions on Unix platforms use uppercase
+           I, except  for  Solaris  (in  its  terminfo  entry  for  screen(1),
+           apparently  based on the X/Open documentation around 1995).  On the
+           other hand, its gs6300 (AT&T PC6300 with EMOTS  Terminal  Emulator)
            description uses lowercase i.
 
-       Some ACS  symbols  (ACS_S3,  ACS_S7,  ACS_LEQUAL,  ACS_GEQUAL,  ACS_PI,
-       ACS_NEQUAL,  and  ACS_STERLING)  were  not  documented  in any publicly
-       released System V.  However, many publicly available  terminfo  entries
-       include  acsc  capabilities in which their key characters (pryz{|}) are
-       embedded, and a second-hand list of their  character  descriptions  has
-       come  to light.  The ncurses developers invented ACS-prefixed names for
+       Some  ACS  symbols  (ACS_S3,  ACS_S7,  ACS_LEQUAL,  ACS_GEQUAL, ACS_PI,
+       ACS_NEQUAL, and ACS_STERLING)  were  not  documented  in  any  publicly
+       released  System V.   However, many publicly available terminfo entries
+       include acsc capabilities in which their key characters  (pryz{|})  are
+       embedded,  and  a  second-hand list of their character descriptions has
+       come to light.  The ncurses developers invented ACS-prefixed names  for
        them.
 
        The displayed values of ACS_ constants depend on
 
        o   the  ncurses  ABI--for  example,  wide-character  versus  non-wide-
-           character  configurations  (the  former  is  capable  of displaying
+           character configurations  (the  former  is  capable  of  displaying
            Unicode while the latter is not), and
 
        o   whether the locale uses UTF-8 encoding.
 
-       In certain cases, the  terminal  is  unable  to  display  forms-drawing
-       characters   except   by   using  UTF-8;  see  the  discussion  of  the
+       In  certain  cases,  the  terminal  is  unable to display forms-drawing
+       characters  except  by  using  UTF-8;  see  the   discussion   of   the
        NCURSES_NO_UTF8_ACS environment variable in ncurses(3x).
 
 
 

Character Set

-       X/Open Curses assumes that the parameter passed to  waddch  contains  a
-       single  character.   That  character may have been more than eight bits
-       wide in an SVr3 or SVr4 implementation, but X/Open  Curses  leaves  the
-       width  of  a non-wide character code unspecified.  The standard further
-       does not specify the internal structure of a chtype, though the use  of
-       bit  operations  to  combine  the  character code with attributes and a
+       X/Open  Curses  assumes  that the parameter passed to waddch contains a
+       single character.  That character may have been more  than  eight  bits
+       wide  in  an  SVr3 or SVr4 implementation, but X/Open Curses leaves the
+       width of a non-wide character code unspecified.  The  standard  further
+       does  not specify the internal structure of a chtype, though the use of
+       bit operations to combine the character  code  with  attributes  and  a
        color pair identifier into a chtype for passage to waddch is common.  A
        portable application uses only the macros discussed in curs_attr(3x) to
        manipulate a chtype.
 
        In ncurses, chtype holds an eight-bit character, but the library allows
-       a  multibyte  character sequence to be passed via a succession of calls
-       to waddch.  Other implementations  do  not;  a  waddch  call  transmits
-       exactly  one  character,  which  may  be rendered in one or more screen
-       locations depending  on  whether  it  is  printable  (see  unctrl(3x)).
-       Depending  on  the  locale,  ncurses  inspects  the byte passed in each
-       waddch call and checks whether the latest call  continues  a  multibyte
-       character.    When  a  character  is  complete,  ncurses  displays  the
-       character  and  advances  the  cursor.   If  the  calling   application
+       a multibyte character sequence to be passed via a succession  of  calls
+       to  waddch.   Other  implementations  do  not;  a waddch call transmits
+       exactly one character, which may be rendered  in  one  or  more  screen
+       locations  depending  on  whether  it  is  printable  (see unctrl(3x)).
+       Depending on the locale, ncurses  inspects  the  byte  passed  in  each
+       waddch  call  and  checks whether the latest call continues a multibyte
+       character.   When  a  character  is  complete,  ncurses  displays   the
+       character   and  advances  the  cursor.   If  the  calling  application
        interrupts the succession of bytes in a multibyte character sequence by
-       changing the current  location--for  example,  with  wmove(3x)--ncurses
+       changing  the  current  location--for  example, with wmove(3x)--ncurses
        discards the incomplete character.
 
        For  portability  to  other  implementations,  do  not  rely  upon  the
-       foregoing behavior.  Check whether a character can be represented as  a
+       foregoing  behavior.  Check whether a character can be represented as a
        single byte in the current locale.
 
        o   If it can, call either waddch or wadd_wch(3x).
@@ -298,22 +301,22 @@
 
 
 

HISTORY

-       The original curses in 4BSD (1980) introduced waddch.
+       4BSD (1980) curses introduced waddch.
 
        SVr3 (1987) added wechochar.
 
 
 

SEE ALSO

-       curs_add_wch(3x)  describes comparable functions of the ncurses library
+       curs_add_wch(3x) describes comparable functions of the ncurses  library
        in its wide-character configuration (ncursesw).
 
        curses(3x),    curs_addchstr(3x),    curs_addstr(3x),    curs_attr(3x),
-       curs_clear(3x),   curs_inch(3x),   curs_outopts(3x),  curs_refresh(3x),
+       curs_clear(3x),  curs_inch(3x),   curs_outopts(3x),   curs_refresh(3x),
        curs_variables(3x), putchar(3)
 
 
 
-ncurses 6.5                       2024-06-08                    curs_addch(3x)
+ncurses 6.5                       2024-06-22                    curs_addch(3x)