]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses-doc.spec
ncurses 6.1 - patch 20190302
[ncurses.git] / Ada95 / package / AdaCurses-doc.spec
1 Summary: AdaCurses - Ada95 binding documentation for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 %define AppPackage %{AppProgram}-doc
6 # $Id: AdaCurses-doc.spec,v 1.5 2018/05/26 20:26:20 tom Exp $
7 Name: %{AppPackage}
8 Version: %{AppVersion}
9 Release: %{AppRelease}
10 License: MIT
11 Group: Applications/Development
12 URL: ftp://ftp.invisible-island.net/%{AppProgram}
13 Source0: %{AppProgram}-%{AppRelease}.tgz
14 Packager: Thomas Dickey <dickey@invisible-island.net>
15
16 %description
17 This is the Ada95 binding documentation from the ncurses MAJOR.MINOR
18 distribution, for patch-date YYYYMMDD.
19 %prep
20
21 %define debug_package %{nil}
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %build
26
27 INSTALL_PROGRAM='${INSTALL}' \
28 %configure \
29         --target %{_target_platform} \
30         --prefix=%{_prefix} \
31         --datadir=%{_datadir} \
32         --with-ada-sharedlib
33
34 %install
35 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
36
37 (cd doc && make install.html DESTDIR=$RPM_BUILD_ROOT )
38
39 %clean
40 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(-,root,root)
44 %{_datadir}/doc/AdaCurses
45
46 %changelog
47 # each patch should add its ChangeLog entries here
48
49 * Sat Mar 26 2011 Thomas Dickey
50 - initial version