]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses-doc.spec
ncurses 5.9 - patch 20110910
[ncurses.git] / Ada95 / package / AdaCurses-doc.spec
1 Summary: AdaCurses - Ada95 binding documentation for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 %define AppPackage %{AppProgram}-doc
6 # $Id: AdaCurses-doc.spec,v 1.1 2011/03/26 19:22:39 tom Exp $
7 Name: %{AppPackage}
8 Version: %{AppVersion}
9 Release: %{AppRelease}
10 License: MIT
11 Group: Applications/Development
12 URL: ftp://invisible-island.net/%{AppProgram}
13 Source0: %{AppProgram}-%{AppRelease}.tgz
14 Packager: Thomas Dickey <dickey@invisible-island.net>
15
16 %description
17 This is the Ada95 binding documentation from the ncurses MAJOR.MINOR
18 distribution, for patch-date YYYYMMDD.
19 %prep
20
21 %setup -q -n %{AppProgram}-%{AppRelease}
22
23 %build
24
25 INSTALL_PROGRAM='${INSTALL}' \
26         ./configure \
27                 --target %{_target_platform} \
28                 --prefix=%{_prefix} \
29                 --datadir=%{_datadir} \
30                 --with-ada-sharedlib
31
32 %install
33 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
34
35 (cd doc && make install.html DESTDIR=$RPM_BUILD_ROOT )
36
37 %clean
38 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(-,root,root)
42 %{_datadir}/doc/AdaCurses
43
44 %changelog
45 # each patch should add its ChangeLog entries here
46
47 * Sat Mar 26 2010 Thomas Dickey
48 - initial version