]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses.spec
ncurses 6.0 - patch 20160130
[ncurses.git] / Ada95 / package / AdaCurses.spec
1 Summary: AdaCurses - Ada95 binding for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: AdaCurses.spec,v 1.15 2015/04/26 23:55:55 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 This is the Ada95 binding from the ncurses MAJOR.MINOR distribution, for
17 patch-date YYYYMMDD.
18
19 In addition to a library, this package installs sample programs in
20 "bin/AdaCurses" to avoid conflict with other packages.
21 %prep
22
23 %define debug_package %{nil}
24
25 # http://fedoraproject.org/wiki/EPEL:Packaging_Autoprovides_and_Requires_Filtering
26 %filter_from_requires /libAdaCurses.so.1/d
27 %filter_setup
28
29 %setup -q -n %{AppProgram}-%{AppRelease}
30
31 %build
32
33 %define ada_libdir %{_prefix}/lib/ada/adalib
34
35 INSTALL_PROGRAM='${INSTALL}' \
36         ./configure \
37                 --target %{_target_platform} \
38                 --prefix=%{_prefix} \
39                 --bindir=%{_bindir} \
40                 --libdir=%{_libdir} \
41                 --mandir=%{_mandir} \
42                 --datadir=%{_datadir} \
43                 --disable-rpath-link \
44                 --with-shared \
45                 --with-ada-sharedlib
46
47 make
48
49 %install
50 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
51
52 make install               DESTDIR=$RPM_BUILD_ROOT
53
54 ( cd samples &&
55   make install.examples \
56         DESTDIR=$RPM_BUILD_ROOT \
57         BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
58 )
59
60 %clean
61 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(-,root,root)
65 %{_bindir}/adacurses*-config
66 %{_bindir}/%{AppProgram}/*
67 %{_libdir}/libAdaCurses.*
68 %{ada_libdir}/libAdaCurses.*
69 %{ada_libdir}/terminal_interface*
70 %{_mandir}/man1/adacurses*-config.1*
71 %{_datadir}/%{AppProgram}/*
72 %{_datadir}/ada/adainclude/terminal_interface*
73
74 %changelog
75 # each patch should add its ChangeLog entries here
76
77 * Thu Mar 31 2011 Thomas Dickey
78 - use --with-shared option for consistency with --with-ada-sharelib
79 - ensure that MY_DATADIR is set when installing examples
80 - add ada_libdir symbol to handle special case where libdir is /usr/lib64
81 - use --disable-rpath-link to link sample programs without rpath
82
83 * Fri Mar 25 2011 Thomas Dickey
84 - initial version