]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses.spec
a3f6e80132f991666ea741f20dcff7e56e0232f2
[ncurses.git] / Ada95 / package / AdaCurses.spec
1 Summary: Ada95 binding for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: AdaCurses.spec,v 1.19 2019/09/08 01:00:18 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://ftp.invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 This is the Ada95 binding from the ncurses MAJOR.MINOR distribution, for
17 patch-date YYYYMMDD.
18
19 In addition to a library, this package installs sample programs in
20 "bin/%{AppProgram}" to avoid conflict with other packages.
21 %prep
22
23 %define debug_package %{nil}
24
25 # http://fedoraproject.org/wiki/EPEL:Packaging_Autoprovides_and_Requires_Filtering
26 %filter_from_requires /lib%{AppProgram}.so.1/d
27 %filter_setup
28
29 %setup -q -n %{AppProgram}-%{AppRelease}
30
31 %build
32
33 %define ada_libdir %{_prefix}/lib/ada/adalib
34 %define ada_include %{_prefix}/share/ada/adainclude
35
36 INSTALL_PROGRAM='${INSTALL}' \
37         ./configure \
38                 --target %{_target_platform} \
39                 --prefix=%{_prefix} \
40                 --bindir=%{_bindir} \
41                 --libdir=%{_libdir} \
42                 --with-ada-include=%{ada_include} \
43                 --with-ada-objects=%{ada_libdir} \
44                 --mandir=%{_mandir} \
45                 --datadir=%{_datadir} \
46                 --disable-rpath-link \
47                 --with-shared \
48                 --with-ada-sharedlib
49
50 make
51
52 %install
53 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
54
55 make install               DESTDIR=$RPM_BUILD_ROOT
56
57 ( cd samples &&
58   make install.examples \
59         DESTDIR=$RPM_BUILD_ROOT \
60         BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
61 )
62
63 %clean
64 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(-,root,root)
68 %{_bindir}/adacurses*-config
69 %{_bindir}/%{AppProgram}/*
70 %{ada_libdir}/lib%{AppProgram}.*
71 %{_mandir}/man1/adacurses*-config.1*
72 %{_datadir}/%{AppProgram}/*
73 %{ada_include}/terminal_interface*
74
75 %changelog
76 # each patch should add its ChangeLog entries here
77
78 * Sat Sep 07 2019 Thomas Dickey
79 - use AppProgram to replace "AdaCurses" globally
80 - amend install-paths to work with Fedora30
81
82 * Thu Mar 31 2011 Thomas Dickey
83 - use --with-shared option for consistency with --with-ada-sharelib
84 - ensure that MY_DATADIR is set when installing examples
85 - add ada_libdir symbol to handle special case where libdir is /usr/lib64
86 - use --disable-rpath-link to link sample programs without rpath
87
88 * Fri Mar 25 2011 Thomas Dickey
89 - initial version