]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/AdaCurses.spec
dc0dc589f923b77d89dc87658abcc7e2a91971b3
[ncurses.git] / Ada95 / package / AdaCurses.spec
1 Summary: AdaCurses - Ada95 binding for ncurses
2 %define AppProgram AdaCurses
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: AdaCurses.spec,v 1.5 2011/03/26 20:41:44 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 This is the Ada95 binding from the ncurses MAJOR.MINOR distribution, for
17 patch-date YYYYMMDD.
18
19 In addition to a library, this package installs sample programs in
20 "bin/AdaCurses" to avoid conflict with other packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %build
26
27 INSTALL_PROGRAM='${INSTALL}' \
28         ./configure \
29                 --target %{_target_platform} \
30                 --prefix=%{_prefix} \
31                 --bindir=%{_bindir} \
32                 --libdir=%{_libdir} \
33                 --mandir=%{_mandir} \
34                 --datadir=%{_datadir} \
35                 --with-ada-sharedlib
36
37 make
38
39 %install
40 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
41
42 make install               DESTDIR=$RPM_BUILD_ROOT
43
44 ( cd samples &&
45   make install.examples \
46         BINDIR=$RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
47 )
48
49 %clean
50 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(-,root,root)
54 %{_bindir}/adacurses*-config
55 %{_bindir}/%{AppProgram}/*
56 %{_libdir}/libAdaCurses.*
57 %{_libdir}/ada/adalib/libAdaCurses.*
58 %{_libdir}/ada/adalib/terminal_interface*
59 %{_mandir}/man1/adacurses*-config.1*
60 %{_datadir}/ada/adainclude/terminal_interface*
61
62 %changelog
63 # each patch should add its ChangeLog entries here
64
65 * Fri Mar 25 2010 Thomas Dickey
66 - initial version