]> ncurses.scripts.mit.edu Git - ncurses.git/blob - Ada95/package/debian/rules
708d3eb2d591129102bc2ab8bb8c7d1a0e54fa7c
[ncurses.git] / Ada95 / package / debian / rules
1 #!/usr/bin/make -f
2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
13
14 TARGET_DIR = $(CURDIR)/debian/adacurses
15 SAMPLE_DIR = $(TARGET_DIR)/usr/bin/AdaCurses
16
17 CFLAGS   = $(shell dpkg-buildflags --get CFLAGS) $(CC_NORMAL)
18 CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
19 LDFLAGS  = $(shell dpkg-buildflags --get LDFLAGS)
20
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22         CFLAGS += -O0
23 else
24         CFLAGS += -O2
25 endif
26 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
27         INSTALL_PROGRAM += -s
28 endif
29
30
31 configure: configure-stamp
32 configure-stamp:
33         dh_testdir
34
35         CFLAGS="$(CFLAGS)" \
36         CPPFLAGS="$(CPPFLAGS)" \
37         LDFLAGS="$(LDFLAGS)" ./configure \
38                 --host=$(DEB_HOST_GNU_TYPE) \
39                 --build=$(DEB_BUILD_GNU_TYPE) \
40                 --prefix=/usr \
41                 --disable-rpath-link \
42                 --with-shared \
43                 --with-ada-sharedlib \
44                 --without-pkg-config
45
46         touch configure-stamp
47
48 build: build-stamp
49 build-stamp: configure-stamp
50         dh_testdir
51
52         $(MAKE)
53
54         touch build-stamp
55
56 clean:
57         dh_testdir
58         dh_testroot
59
60         [ ! -f makefile ] || $(MAKE) distclean
61
62         rm -f configure-stamp build-stamp install-stamp
63
64         dh_clean
65
66 install: install-stamp
67 install-stamp: build-stamp
68         dh_testdir
69         dh_testroot
70         dh_clean -k
71         dh_installdirs
72
73         $(MAKE) install DESTDIR=$(TARGET_DIR)
74         
75         # FIXME: it would be nice to make these into separate packages
76         ( cd samples && $(MAKE) install.examples DESTDIR=$(TARGET_DIR) BINDIR=$(SAMPLE_DIR) )
77         ( cd doc && $(MAKE) install.html DESTDIR=$(TARGET_DIR) )
78
79         touch install-stamp
80
81 # Build architecture-independent files here.
82 binary-indep: build install
83 # No binary-indep target.
84
85 # Build architecture-dependent files here.
86 binary-arch: build install
87         dh_testdir
88         dh_testroot
89         dh_installdocs
90         dh_installexamples
91         dh_installchangelogs NEWS
92         dh_strip
93         dh_compress
94         dh_fixperms
95         dh_installdeb
96         dh_makeshlibs
97         dh_shlibdeps
98         dh_gencontrol
99         dh_md5sums
100         dh_builddeb
101
102 binary: binary-indep binary-arch
103 .PHONY: build clean binary-indep binary-arch binary install install-stamp