]> ncurses.scripts.mit.edu Git - ncurses.git/blob - package/mingw-ncurses.spec
48a645b38d3fa66a78dda44242f3b4241fad8f3c
[ncurses.git] / package / mingw-ncurses.spec
1 %?mingw_package_header
2
3 Summary: shared libraries for terminal handling
4 Name: mingw32-ncurses6
5 Version: 6.1
6 Release: 20180428
7 License: X11
8 Group: Development/Libraries
9 Source: ncurses-%{version}-%{release}.tgz
10 # URL: https://invisible-island.net/ncurses/
11
12 BuildRequires:  mingw32-filesystem >= 95
13 BuildRequires:  mingw32-gcc
14 BuildRequires:  mingw32-binutils
15
16 BuildRequires:  mingw64-filesystem >= 95
17 BuildRequires:  mingw64-gcc
18 BuildRequires:  mingw64-binutils
19
20 %global MY_ABI 6
21
22 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
23 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
24
25 %description -n mingw32-ncurses6
26 Cross-compiling support for ncurses to mingw32.
27
28 The ncurses library routines are a terminal-independent method of
29 updating character screens with reasonable optimization.
30
31 This package is used for testing ABI 6 with cross-compiles to MinGW.
32
33 %package -n mingw64-ncurses6
34 Summary:        Curses library for MinGW64
35
36 %description -n mingw64-ncurses6
37 Cross-compiling support for ncurses to mingw64.
38
39 The ncurses library routines are a terminal-independent method of
40 updating character screens with reasonable optimization.
41
42 This package is used for testing ABI %{MY_ABI} with cross-compiles to MinGW.
43
44 %prep
45
46 %define CFG_OPTS \\\
47         --disable-db-install \\\
48         --disable-echo \\\
49         --disable-getcap \\\
50         --disable-hard-tabs \\\
51         --disable-leaks \\\
52         --disable-macros \\\
53         --disable-overwrite \\\
54         --disable-termcap \\\
55         --enable-interop \\\
56         --enable-opaque-curses \\\
57         --enable-opaque-form \\\
58         --enable-opaque-menu \\\
59         --enable-opaque-panel \\\
60         --enable-pc-files \\\
61         --enable-sp-funcs \\\
62         --enable-term-driver \\\
63         --enable-warnings \\\
64         --enable-wgetch-events \\\
65         --enable-widec \\\
66         --with-config-suffix=dev \\\
67         --verbose \\\
68         --with-cxx-shared \\\
69         --with-develop \\\
70         --with-fallbacks=unknown,xterm \\\
71         --with-install-prefix=$RPM_BUILD_ROOT \\\
72         --with-pc-suffix=%{MY_ABI} \\\
73         --with-shared \\\
74         --with-tparm-arg=intptr_t \\\
75         --with-trace \\\
76         --with-xterm-kbs=DEL \\\
77         --without-ada \\\
78         --without-debug \\\
79         --without-manpages \\\
80         --without-progs \\\
81         --without-tests
82
83 %define debug_package %{nil}
84 %setup -q -n ncurses-%{version}-%{release}
85
86 %build
87 mkdir BUILD-W32
88 pushd BUILD-W32
89 CFLAGS="%{CC_NORMAL}" \
90 CC=%{mingw32_cc} \
91 %mingw32_configure %{CFG_OPTS} \
92         --with-pkg-config-libdir=%{mingw32_libdir}/pkgconfig
93 make
94 popd
95
96 mkdir BUILD-W64
97 pushd BUILD-W64
98 CFLAGS="%{CC_NORMAL}" \
99 CC=%{mingw64_cc} \
100 %mingw64_configure %{CFG_OPTS} \
101         --with-pkg-config-libdir=%{mingw64_libdir}/pkgconfig
102 make
103 popd
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 mkdir -p $RPM_BUILD_ROOT%{_bindir}
109
110 pushd BUILD-W32
111 %{mingw32_make} install.libs
112 for name in $RPM_BUILD_ROOT%{mingw32_bindir}/*-config; \
113         do \
114                 base=`basename $name`; \
115                 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw32_target}-$base; \
116         done
117 popd
118
119 pushd BUILD-W64
120 %{mingw64_make} install.libs
121 for name in $RPM_BUILD_ROOT%{mingw64_bindir}/*-config; \
122         do \
123                 base=`basename $name`; \
124                 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw64_target}-$base; \
125         done
126 popd
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -n mingw32-ncurses6
132 %defattr(-,root,root,-)
133 %{_bindir}/%{mingw32_target}-*
134 %{mingw32_bindir}/*
135 %{mingw32_includedir}/*
136 %{mingw32_libdir}/*
137
138 %files -n mingw64-ncurses6
139 %defattr(-,root,root,-)
140 %{_bindir}/%{mingw64_target}-*
141 %{mingw64_bindir}/*
142 %{mingw64_includedir}/*
143 %{mingw64_libdir}/*
144
145 %changelog
146
147 * Sat Feb 10 2018 Thomas E. Dickey
148 - add several development features
149
150 * Tue Dec 26 2017 Thomas E. Dickey
151 - add --with-config-suffix option
152
153 * Sat Sep 20 2014 Thomas E. Dickey
154 - adjust install-rules for ncurses*-config
155
156 * Sat Aug 03 2013 Thomas E. Dickey
157 - initial version, using mingw-pdcurses package as a guide.