]> ncurses.scripts.mit.edu Git - ncurses.git/blob - package/mingw-ncurses.spec
a3ef00d497751bdeacf365fd93c68600b574c818
[ncurses.git] / package / mingw-ncurses.spec
1 %?mingw_package_header
2
3 Summary: shared libraries for terminal handling
4 Name: mingw32-ncurses6
5 Version: 6.1
6 Release: 20180922
7 License: X11
8 Group: Development/Libraries
9 Source: ncurses-%{version}-%{release}.tgz
10 # URL: https://invisible-island.net/ncurses/
11
12 BuildRequires:  mingw32-filesystem >= 95
13 BuildRequires:  mingw32-gcc
14 BuildRequires:  mingw32-binutils
15
16 BuildRequires:  mingw64-filesystem >= 95
17 BuildRequires:  mingw64-gcc
18 BuildRequires:  mingw64-binutils
19
20 %global MY_ABI 6
21
22 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
23 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
24
25 %description -n mingw32-ncurses6
26 Cross-compiling support for ncurses to mingw32.
27
28 The ncurses library routines are a terminal-independent method of
29 updating character screens with reasonable optimization.
30
31 This package is used for testing ABI 6 with cross-compiles to MinGW.
32
33 %package -n mingw64-ncurses6
34 Summary:        Curses library for MinGW64
35
36 %description -n mingw64-ncurses6
37 Cross-compiling support for ncurses to mingw64.
38
39 The ncurses library routines are a terminal-independent method of
40 updating character screens with reasonable optimization.
41
42 This package is used for testing ABI %{MY_ABI} with cross-compiles to MinGW.
43
44 %prep
45
46 %define CFG_OPTS \\\
47         --disable-db-install \\\
48         --disable-echo \\\
49         --disable-getcap \\\
50         --disable-hard-tabs \\\
51         --disable-leaks \\\
52         --disable-macros \\\
53         --disable-overwrite \\\
54         --disable-termcap \\\
55         --enable-interop \\\
56         --enable-opaque-curses \\\
57         --enable-opaque-form \\\
58         --enable-opaque-menu \\\
59         --enable-opaque-panel \\\
60         --enable-pc-files \\\
61         --enable-sp-funcs \\\
62         --enable-term-driver \\\
63         --enable-warnings \\\
64         --enable-wgetch-events \\\
65         --enable-widec \\\
66         --with-config-suffix=dev \\\
67         --verbose \\\
68         --with-cxx-shared \\\
69         --with-develop \\\
70         --with-fallbacks=unknown,xterm \\\
71         --with-install-prefix=$RPM_BUILD_ROOT \\\
72         --with-pc-suffix=%{MY_ABI} \\\
73         --with-pcre2 \\\
74         --with-shared \\\
75         --with-tparm-arg=intptr_t \\\
76         --with-trace \\\
77         --with-xterm-kbs=DEL \\\
78         --without-ada \\\
79         --without-debug \\\
80         --without-manpages \\\
81         --without-progs \\\
82         --without-tests
83
84 %define debug_package %{nil}
85 %setup -q -n ncurses-%{version}-%{release}
86
87 %build
88 mkdir BUILD-W32
89 pushd BUILD-W32
90 CFLAGS="%{CC_NORMAL}" \
91 CC=%{mingw32_cc} \
92 %mingw32_configure %{CFG_OPTS} \
93         --with-pkg-config-libdir=%{mingw32_libdir}/pkgconfig
94 make
95 popd
96
97 mkdir BUILD-W64
98 pushd BUILD-W64
99 CFLAGS="%{CC_NORMAL}" \
100 CC=%{mingw64_cc} \
101 %mingw64_configure %{CFG_OPTS} \
102         --with-pkg-config-libdir=%{mingw64_libdir}/pkgconfig
103 make
104 popd
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 mkdir -p $RPM_BUILD_ROOT%{_bindir}
110
111 pushd BUILD-W32
112 %{mingw32_make} install.libs
113 for name in $RPM_BUILD_ROOT%{mingw32_bindir}/*-config; \
114         do \
115                 base=`basename $name`; \
116                 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw32_target}-$base; \
117         done
118 popd
119
120 pushd BUILD-W64
121 %{mingw64_make} install.libs
122 for name in $RPM_BUILD_ROOT%{mingw64_bindir}/*-config; \
123         do \
124                 base=`basename $name`; \
125                 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw64_target}-$base; \
126         done
127 popd
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files -n mingw32-ncurses6
133 %defattr(-,root,root,-)
134 %{_bindir}/%{mingw32_target}-*
135 %{mingw32_bindir}/*
136 %{mingw32_includedir}/*
137 %{mingw32_libdir}/*
138
139 %files -n mingw64-ncurses6
140 %defattr(-,root,root,-)
141 %{_bindir}/%{mingw64_target}-*
142 %{mingw64_bindir}/*
143 %{mingw64_includedir}/*
144 %{mingw64_libdir}/*
145
146 %changelog
147
148 * Sat Feb 10 2018 Thomas E. Dickey
149 - add several development features
150
151 * Tue Dec 26 2017 Thomas E. Dickey
152 - add --with-config-suffix option
153
154 * Sat Sep 20 2014 Thomas E. Dickey
155 - adjust install-rules for ncurses*-config
156
157 * Sat Aug 03 2013 Thomas E. Dickey
158 - initial version, using mingw-pdcurses package as a guide.