]> ncurses.scripts.mit.edu Git - ncurses.git/blob - package/ncurses.spec
1d62fe5aee593de08fdd4fecf9b83f68b6cc8cd7
[ncurses.git] / package / ncurses.spec
1 Summary: shared libraries for terminal handling
2 Name: ncurses6
3 Release: 5.9
4 Version: 20120622
5 License: X11
6 Group: Development/Libraries
7 Source: ncurses-%{release}-%{version}.tgz
8 # URL: http://invisible-island.net/ncurses/
9
10 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
11 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
12
13 %define _prefix /usr/local/ncurses6
14 %define MYDATA /usr/local/ncurses/share/terminfo
15
16 %description
17 The ncurses library routines are a terminal-independent method of
18 updating character screens with reasonable optimization.
19
20 This package is used for testing ABI 6.
21
22 %prep
23
24 %setup -q -n ncurses-%{release}-%{version}
25
26 %build
27 CFLAGS="%{CC_NORMAL}" \
28 RPATH_LIST=../lib:%{_prefix}/lib \
29 %configure \
30         --target %{_target_platform} \
31         --prefix=%{_prefix} \
32         --includedir='${prefix}/include' \
33         --with-default-terminfo-dir=%{MYDATA} \
34         --with-install-prefix=$RPM_BUILD_ROOT \
35         --with-terminfo-dirs=%{MYDATA}:/usr/share/terminfo \
36         --disable-echo \
37         --disable-getcap \
38         --disable-leaks \
39         --disable-macros  \
40         --disable-overwrite  \
41         --disable-termcap \
42         --enable-const \
43         --enable-ext-colors \
44         --enable-ext-mouse \
45         --enable-hard-tabs \
46         --enable-rpath \
47         --enable-sp-funcs \
48         --enable-warnings \
49         --enable-widec \
50         --verbose \
51         --with-develop \
52         --with-shared \
53         --with-termlib \
54         --with-ticlib \
55         --with-trace \
56         --with-xterm-kbs=DEL \
57         --without-ada \
58         --without-debug \
59         --without-normal
60
61 make
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 make install.libs install.progs
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(-,root,root,-)
73 %{_bindir}/*
74 %{_includedir}/*
75 %{_libdir}/*
76 #%{_datadir}/*
77
78 %changelog
79
80 * Fri Jun 08 2012 Thomas E. Dickey
81 - initial version.