]> ncurses.scripts.mit.edu Git - ncurses.git/blob - test/package/ncurses-examples.spec
ncurses 5.9 - patch 20131019
[ncurses.git] / test / package / ncurses-examples.spec
1 Summary: ncurses-examples - example/test programs from ncurses
2 %define AppProgram ncurses-examples
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: ncurses-examples.spec,v 1.3 2013/10/05 23:44:19 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 These are the example/test programs from the ncurses MAJOR.MINOR distribution,
17 for patch-date YYYYMMDD.
18
19 This package installs in "bin/ncurses-examples" to avoid conflict with other
20 packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %build
26
27 INSTALL_PROGRAM='${INSTALL}' \
28         ./configure \
29                 --target %{_target_platform} \
30                 --prefix=%{_prefix} \
31                 --bindir=%{_bindir}/%{AppProgram} \
32                 --with-ncursesw \
33                 --disable-rpath-hack
34
35 make
36
37 %install
38 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
39
40 make install               DESTDIR=$RPM_BUILD_ROOT
41
42 strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}/*
43
44 %clean
45 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(-,root,root)
49 %{_bindir}/%{AppProgram}/*
50
51 %changelog
52 # each patch should add its ChangeLog entries here
53
54 * Thu Mar 25 2010 Thomas Dickey
55 - initial version