]> ncurses.scripts.mit.edu Git - ncurses.git/blob - test/package/ncurses-examples.spec
ncurses 6.0 - patch 20171230
[ncurses.git] / test / package / ncurses-examples.spec
1 Summary: ncurses-examples - example/test programs from ncurses
2 %define AppProgram ncurses-examples
3 %define AppVersion MAJOR.MINOR
4 %define AppRelease YYYYMMDD
5 # $Id: ncurses-examples.spec,v 1.10 2017/12/26 23:54:06 tom Exp $
6 Name: %{AppProgram}
7 Version: %{AppVersion}
8 Release: %{AppRelease}
9 License: MIT
10 Group: Applications/Development
11 URL: ftp://ftp.invisible-island.net/%{AppProgram}
12 Source0: %{AppProgram}-%{AppRelease}.tgz
13 Packager: Thomas Dickey <dickey@invisible-island.net>
14
15 %description
16 These are the example/test programs from the ncurses MAJOR.MINOR distribution,
17 for patch-date YYYYMMDD.
18
19 This package installs in "bin/ncurses-examples" to avoid conflict with other
20 packages.
21 %prep
22
23 %setup -q -n %{AppProgram}-%{AppRelease}
24
25 %define debug_package %{nil}
26
27 %build
28
29 INSTALL_PROGRAM='${INSTALL}' \
30 NCURSES_CONFIG_SUFFIX=dev \
31 %configure \
32         --target %{_target_platform} \
33         --prefix=%{_prefix} \
34         --bindir=%{_bindir}/%{AppProgram} \
35         --datadir=%{_datadir}/%{AppProgram} \
36         --with-screen=ncursesw6 \
37         --disable-rpath-hack
38
39 make
40
41 %install
42 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
43
44 make install               DESTDIR=$RPM_BUILD_ROOT
45
46 strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}/*
47
48 %clean
49 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(-,root,root)
53 %{_bindir}/%{AppProgram}/*
54 %{_datadir}/%{AppProgram}/*
55
56 %changelog
57 # each patch should add its ChangeLog entries here
58
59 * Sat Nov 11 2017 Thomas Dickey
60 - add example data-files
61 - use rpm built-in "configure"
62 - suppress debug-package
63
64 * Thu Mar 25 2010 Thomas Dickey
65 - initial version