]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.2 - patch 20210703
[ncurses.git] / Ada95 / configure.in
index 51674b298223ab8a0de8dbbe64d484c7d9fe5968..1d86d825d1ce7c4bd7a1795c2025450be6584104 100644 (file)
@@ -1,5 +1,6 @@
 dnl***************************************************************************
 dnl***************************************************************************
-dnl Copyright (c) 2010-2013,2014 Free Software Foundation, Inc.              *
+dnl Copyright 2018-2020,2021 Thomas E. Dickey                                *
+dnl Copyright 2010-2016,2018 Free Software Foundation, Inc.                  *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,19 +29,25 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.55 2014/06/01 16:40:55 tom Exp $
+dnl $Id: configure.in,v 1.83 2021/07/03 20:23:24 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
 dnl Process this file with autoconf to produce a configure script.
 dnl
-dnl See http://invisible-island.net/autoconf/ for additional information.
+dnl For additional information, see
+dnl     https://invisible-island.net/autoconf/
+dnl     https://invisible-island.net/autoconf/my-autoconf.html
 dnl
 dnl ---------------------------------------------------------------------------
 dnl
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.52.20030208)
-AC_REVISION($Revision: 1.55 $)
+AC_PREREQ(2.52.20210509)
+AC_REVISION($Revision: 1.83 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
+AC_DEFUN([AC_PATH_XTRA],[])dnl ignore dependencies on this
+
 CF_TOP_BUILDDIR
 
 CF_TOP_BUILDDIR
 
+CF_HELP_MESSAGE(General Options:)
+
 CF_WITH_SYSTYPE
 
 ###    Save the given $CFLAGS to allow user-override.
 CF_WITH_SYSTYPE
 
 ###    Save the given $CFLAGS to allow user-override.
@@ -53,7 +60,7 @@ CF_CFG_DEFAULTS
 CF_PROG_CC(gnatgcc gcc cc)
 AC_PROG_CPP
 AC_PROG_GCC_TRADITIONAL
 CF_PROG_CC(gnatgcc gcc cc)
 AC_PROG_CPP
 AC_PROG_GCC_TRADITIONAL
-CF_PROG_CC_C_O(CC)
+CF_PROG_CC_C_O(CC,[$CFLAGS $CPPFLAGS])
 
 AC_ARG_PROGRAM
 
 
 AC_ARG_PROGRAM
 
@@ -62,6 +69,9 @@ CF_PROG_EGREP
 AC_PROG_INSTALL
 CF_PROG_LN_S
 
 AC_PROG_INSTALL
 CF_PROG_LN_S
 
+CF_PROG_INSTALL
+CF_INSTALL_OPTS
+
 AC_SYS_LONG_FILE_NAMES
 
 # if we find pkg-config, check if we should install the ".pc" files.
 AC_SYS_LONG_FILE_NAMES
 
 # if we find pkg-config, check if we should install the ".pc" files.
@@ -82,16 +92,17 @@ AC_ARG_ENABLE(mixed-case,
        [enable_mixedcase=auto])
 AC_MSG_RESULT($enable_mixedcase)
 if test "$enable_mixedcase" = "auto" ; then
        [enable_mixedcase=auto])
 AC_MSG_RESULT($enable_mixedcase)
 if test "$enable_mixedcase" = "auto" ; then
-    CF_MIXEDCASE_FILENAMES
+       CF_MIXEDCASE_FILENAMES
 else
 else
-    cf_cv_mixedcase=$enable_mixedcase
-    if test "$enable_mixedcase" = "yes" ; then
-        AC_DEFINE(MIXEDCASE_FILENAMES)
-    fi
+       cf_cv_mixedcase=$enable_mixedcase
+       if test "$enable_mixedcase" = "yes" ; then
+               AC_DEFINE(MIXEDCASE_FILENAMES)
+       fi
 fi
 
 # do this after mixed-case option (tags/TAGS is not as important as tic).
 AC_PROG_MAKE_SET
 fi
 
 # do this after mixed-case option (tags/TAGS is not as important as tic).
 AC_PROG_MAKE_SET
+CF_MAKE_PHONY
 CF_MAKE_TAGS
 CF_MAKEFLAGS
 
 CF_MAKE_TAGS
 CF_MAKEFLAGS
 
@@ -108,10 +119,10 @@ dnl archive can be built without modifying the host system's configuration.
 AC_MSG_CHECKING(if you have specified an install-prefix)
 AC_ARG_WITH(install-prefix,
        [  --with-install-prefix   prefixes actual install-location ($DESTDIR)],
 AC_MSG_CHECKING(if you have specified an install-prefix)
 AC_ARG_WITH(install-prefix,
        [  --with-install-prefix   prefixes actual install-location ($DESTDIR)],
-       [case "$withval" in #(vi
-       yes|no) #(vi
+       [case "$withval" in
+       (yes|no)
                ;;
                ;;
-       *)      DESTDIR="$withval"
+       (*)     DESTDIR="$withval"
                ;;
        esac])
 AC_MSG_RESULT($DESTDIR)
                ;;
        esac])
 AC_MSG_RESULT($DESTDIR)
@@ -174,10 +185,10 @@ AC_SUBST(CC_G_OPT)
 
 AC_MSG_CHECKING(for default loader flags)
 case $DFT_LWR_MODEL in
 
 AC_MSG_CHECKING(for default loader flags)
 case $DFT_LWR_MODEL in
-normal)  LD_MODEL=''   ;;
-debug)   LD_MODEL=$CC_G_OPT ;;
-profile) LD_MODEL='-pg';;
-shared)  LD_MODEL=''   ;;
+(normal)  LD_MODEL=''   ;;
+(debug)   LD_MODEL=$CC_G_OPT ;;
+(profile) LD_MODEL='-pg';;
+(shared)  LD_MODEL=''   ;;
 esac
 AC_SUBST(LD_MODEL)dnl          the type of link (e.g., -g or -pg)
 AC_MSG_RESULT($LD_MODEL)
 esac
 AC_SUBST(LD_MODEL)dnl          the type of link (e.g., -g or -pg)
 AC_MSG_RESULT($LD_MODEL)
@@ -205,30 +216,10 @@ fi
 CF_HELP_MESSAGE(Fine-Tuning Your Configuration:)
 
 ###   use option --enable-broken-linker to force on use of broken-linker support
 CF_HELP_MESSAGE(Fine-Tuning Your Configuration:)
 
 ###   use option --enable-broken-linker to force on use of broken-linker support
-AC_MSG_CHECKING(if you want broken-linker support code)
-AC_ARG_ENABLE(broken_linker,
-       [  --enable-broken_linker  compile with broken-linker support code],
-       [with_broken_linker=$enableval],
-       [with_broken_linker=${BROKEN_LINKER:-no}])
-AC_MSG_RESULT($with_broken_linker)
-
-BROKEN_LINKER=0
-if test "$with_broken_linker" = yes ; then
-       AC_DEFINE(BROKEN_LINKER)
-       BROKEN_LINKER=1
-elif test "$DFT_LWR_MODEL" = shared ; then
-       case $cf_cv_system_name in #(vi
-       cygwin*)
-               AC_DEFINE(BROKEN_LINKER)
-               BROKEN_LINKER=1
-               CF_VERBOSE(cygwin linker is broken anyway)
-               ;;
-       esac
-fi
-AC_SUBST(BROKEN_LINKER)
+CF_ENABLE_BROKEN_LINKER
 
 # Check to define _XOPEN_SOURCE "automatically"
 
 # Check to define _XOPEN_SOURCE "automatically"
-CF_XOPEN_SOURCE
+CF_XOPEN_SOURCE(600)
 
 CF_LARGEFILE
 
 
 CF_LARGEFILE
 
@@ -293,27 +284,27 @@ CF_WITH_PTHREAD
 
 AC_MSG_CHECKING(if you want to use weak-symbols for pthreads)
 AC_ARG_ENABLE(weak-symbols,
 
 AC_MSG_CHECKING(if you want to use weak-symbols for pthreads)
 AC_ARG_ENABLE(weak-symbols,
-    [  --enable-weak-symbols   enable weak-symbols for pthreads],
-    [use_weak_symbols=$withval],
-    [use_weak_symbols=no])
+       [  --enable-weak-symbols   enable weak-symbols for pthreads],
+       [use_weak_symbols=$withval],
+       [use_weak_symbols=no])
 AC_MSG_RESULT($use_weak_symbols)
 if test "$use_weak_symbols" = yes ; then
 AC_MSG_RESULT($use_weak_symbols)
 if test "$use_weak_symbols" = yes ; then
-    CF_WEAK_SYMBOLS
+       CF_WEAK_SYMBOLS
 else
 else
-    cf_cv_weak_symbols=no
+       cf_cv_weak_symbols=no
 fi
 
 if test $cf_cv_weak_symbols = yes ; then
 fi
 
 if test $cf_cv_weak_symbols = yes ; then
-    AC_DEFINE(USE_WEAK_SYMBOLS,1,[Define to 1 to enable weak-symbols for pthreads])
+       AC_DEFINE(USE_WEAK_SYMBOLS,1,[Define to 1 to enable weak-symbols for pthreads])
 fi
 
 PTHREAD=
 if test "$with_pthread" = "yes" ; then
 fi
 
 PTHREAD=
 if test "$with_pthread" = "yes" ; then
-    AC_DEFINE(USE_PTHREADS,1,[Define to 1 to use the pthreads library])
-    enable_reentrant=yes
-    if test $cf_cv_weak_symbols = yes ; then
-        PTHREAD=-lpthread
-    fi
+       AC_DEFINE(USE_PTHREADS,1,[Define to 1 to use the pthreads library])
+       enable_reentrant=yes
+       if test $cf_cv_weak_symbols = yes ; then
+               PTHREAD=-lpthread
+       fi
 fi
 AC_SUBST(PTHREAD)
 
 fi
 AC_SUBST(PTHREAD)
 
@@ -363,18 +354,10 @@ CF_HELP_MESSAGE(Testing/development Options:)
 ###    use option --disable-echo to suppress full display compiling commands
 CF_DISABLE_ECHO
 
 ###    use option --disable-echo to suppress full display compiling commands
 CF_DISABLE_ECHO
 
-###    use option --enable-warnings to turn on all gcc warnings
-AC_MSG_CHECKING(if you want to see compiler warnings)
-AC_ARG_ENABLE(warnings,
-       [  --enable-warnings       build: turn on GCC compiler warnings],
-       [with_warnings=$enableval])
-AC_MSG_RESULT($with_warnings)
-
-if test "x$with_warnings" = "xyes"; then
+CF_ENABLE_WARNINGS(Wno-unknown-pragmas Wswitch-enum,yes)
+if test "x$enable_warnings" = "xyes"; then
        CF_ADD_ADAFLAGS(-gnatg)
        CF_ADD_ADAFLAGS(-gnatg)
-       CF_GCC_WARNINGS(Wno-unknown-pragmas Wswitch-enum)
 fi
 fi
-CF_GCC_ATTRIBUTES
 
 ###    use option --enable-assertions to turn on generation of assertion code
 AC_MSG_CHECKING(if you want to enable runtime assertions)
 
 ###    use option --enable-assertions to turn on generation of assertion code
 AC_MSG_CHECKING(if you want to enable runtime assertions)
@@ -410,7 +393,7 @@ AC_ARG_ENABLE(macros,
 # extended to all models of the ncurses library:
 cf_all_traces=no
 case "$CFLAGS $CPPFLAGS" in
 # extended to all models of the ncurses library:
 cf_all_traces=no
 case "$CFLAGS $CPPFLAGS" in
-*-DTRACE*)
+(*-DTRACE*)
        cf_all_traces=yes
        ;;
 esac
        cf_all_traces=yes
        ;;
 esac
@@ -434,10 +417,10 @@ AC_SUBST(ADA_TRACE)
 CF_DISABLE_GNAT_PROJECTS
 
 ###    Checks for libraries.
 CF_DISABLE_GNAT_PROJECTS
 
 ###    Checks for libraries.
-case $cf_cv_system_name in #(vi
-*mingw32*) #(vi
+case $cf_cv_system_name in
+(*mingw32*)
        ;;
        ;;
-*)
+(*)
 AC_CHECK_FUNC(gettimeofday,
        AC_DEFINE(HAVE_GETTIMEOFDAY),[
 
 AC_CHECK_FUNC(gettimeofday,
        AC_DEFINE(HAVE_GETTIMEOFDAY),[
 
@@ -448,6 +431,7 @@ AC_CHECK_LIB(bsd, gettimeofday,
 esac
 
 ###    Checks for header files.
 esac
 
 ###    Checks for header files.
+AC_CHECK_SIZEOF([signed char])
 AC_STDC_HEADERS
 AC_HEADER_DIRENT
 AC_HEADER_TIME
 AC_STDC_HEADERS
 AC_HEADER_DIRENT
 AC_HEADER_TIME
@@ -477,6 +461,8 @@ if test "$cf_with_ada" != "no" ; then
        if test "$cf_cv_prog_gnat_correct" = yes; then
                CF_FIXUP_ADAFLAGS
 
        if test "$cf_cv_prog_gnat_correct" = yes; then
                CF_FIXUP_ADAFLAGS
 
+               CF_GNATPREP_OPT_T
+
                CF_GNAT_GENERICS
                CF_GNAT_SIGINT
                CF_GNAT_PROJECTS
                CF_GNAT_GENERICS
                CF_GNAT_SIGINT
                CF_GNAT_PROJECTS
@@ -489,6 +475,9 @@ if test "$cf_with_ada" != "no" ; then
                CF_WITH_ADA_INCLUDE
                CF_WITH_ADA_OBJECTS
                CF_WITH_ADA_SHAREDLIB
                CF_WITH_ADA_INCLUDE
                CF_WITH_ADA_OBJECTS
                CF_WITH_ADA_SHAREDLIB
+
+               # allow the Ada binding to be renamed
+               CF_WITH_ADA_LIBNAME(AdaCurses)
        else
                AC_MSG_ERROR(No usable Ada compiler found)
        fi
        else
                AC_MSG_ERROR(No usable Ada compiler found)
        fi
@@ -527,26 +516,32 @@ AC_MSG_RESULT($DFT_OBJ_SUBDIR)
 ### Set up low-level terminfo dependencies for makefiles.
 
 if test "$DFT_LWR_MODEL" = shared ; then
 ### Set up low-level terminfo dependencies for makefiles.
 
 if test "$DFT_LWR_MODEL" = shared ; then
-       case $cf_cv_system_name in #(vi
-       cygwin*)
+       case $cf_cv_system_name in
+       (cygwin*)
                # "lib" files have ".dll.a" suffix, "cyg" files have ".dll"
                ;;
                # "lib" files have ".dll.a" suffix, "cyg" files have ".dll"
                ;;
-       msys*)
+       (msys*)
                # "lib" files have ".dll.a" suffix, "msys-" files have ".dll"
                ;;
        esac
 fi
 
                # "lib" files have ".dll.a" suffix, "msys-" files have ".dll"
                ;;
        esac
 fi
 
+USE_ARG_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_ARG_SUFFIX)
+
+USE_LIB_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_LIB_SUFFIX)
+
+USE_CFG_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_CFG_SUFFIX)
+
 ### Construct the list of subdirectories for which we'll customize makefiles
 ### with the appropriate compile-rules.
 
 ### Construct the list of subdirectories for which we'll customize makefiles
 ### with the appropriate compile-rules.
 
-SUB_MAKEFILES="gen/adacurses${DFT_ARG_SUFFIX}-config:gen/adacurses-config.in"
+SUB_MAKEFILES="gen/adacurses${USE_ARG_SUFFIX}-config:gen/adacurses-config.in"
 
 AC_DEFINE_UNQUOTED(NCURSES_PATHSEP,'$PATH_SEPARATOR',[Define to override ':' as the library path-separator])
 
 
 AC_DEFINE_UNQUOTED(NCURSES_PATHSEP,'$PATH_SEPARATOR',[Define to override ':' as the library path-separator])
 
-### Now that we're done running tests, add the compiler-warnings, if any
-CF_ADD_CFLAGS($EXTRA_CFLAGS)
-
 ################################################################################
 
 TEST_ARG2=
 ################################################################################
 
 TEST_ARG2=
@@ -579,8 +574,17 @@ AC_SUBST(EXTERNAL_TREE)
 ADAHTML_DIR=../doc/ada
 AC_SUBST(ADAHTML_DIR)
 
 ADAHTML_DIR=../doc/ada
 AC_SUBST(ADAHTML_DIR)
 
+if test "x$cross_compiling" = xyes ; then
+       ADAGEN_LDFLAGS='$(CROSS_LDFLAGS)'
+else
+       ADAGEN_LDFLAGS='$(NATIVE_LDFLAGS)'
+fi
+
+AC_SUBST(ADAGEN_LDFLAGS)
+
 AC_OUTPUT( \
        $SUB_MAKEFILES \
 AC_OUTPUT( \
        $SUB_MAKEFILES \
+       src/library.gpr:src/library.gpr.in \
        doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in \
        Makefile,[
 if test -z "$USE_OLD_MAKERULES" ; then
        doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in \
        Makefile,[
 if test -z "$USE_OLD_MAKERULES" ; then
@@ -601,6 +605,8 @@ NCURSES_MAJOR="$NCURSES_MAJOR"
 NCURSES_MINOR="$NCURSES_MINOR"
 NCURSES_PATCH="$NCURSES_PATCH"
 USE_OLD_MAKERULES="$USE_OLD_MAKERULES"
 NCURSES_MINOR="$NCURSES_MINOR"
 NCURSES_PATCH="$NCURSES_PATCH"
 USE_OLD_MAKERULES="$USE_OLD_MAKERULES"
+cf_cv_VERSION_GNATMAKE=$cf_cv_VERSION_GNATMAKE
+cf_cv_VERSION_GPRBUILD=$cf_cv_VERSION_GPRBUILD
 cf_cv_abi_version="$cf_cv_abi_version"
 cf_cv_rel_version="$cf_cv_rel_version"
 cf_cv_rm_so_locs="$cf_cv_rm_so_locs"
 cf_cv_abi_version="$cf_cv_abi_version"
 cf_cv_rel_version="$cf_cv_rel_version"
 cf_cv_rm_so_locs="$cf_cv_rm_so_locs"