]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.3 - patch 20220305
[ncurses.git] / Ada95 / configure.in
index eb544d4c26095a5b10f86fc8265b96b46f8049fc..1fbd5935533868f58091340a85a4a3e17b77800f 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright 2018-2020,2021 Thomas E. Dickey                                *
+dnl Copyright 2018-2021,2022 Thomas E. Dickey                                *
 dnl Copyright 2010-2016,2018 Free Software Foundation, Inc.                  *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
@@ -29,7 +29,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.82 2021/01/09 11:20:33 tom Exp $
+dnl $Id: configure.in,v 1.85 2022/03/05 22:20:52 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
 dnl For additional information, see
@@ -37,8 +37,8 @@ dnl     https://invisible-island.net/autoconf/
 dnl     https://invisible-island.net/autoconf/my-autoconf.html
 dnl
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.52.20200111)
-AC_REVISION($Revision: 1.82 $)
+AC_PREREQ(2.52.20210509)
+AC_REVISION($Revision: 1.85 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
@@ -102,6 +102,7 @@ fi
 
 # do this after mixed-case option (tags/TAGS is not as important as tic).
 AC_PROG_MAKE_SET
+CF_MAKE_PHONY
 CF_MAKE_TAGS
 CF_MAKEFLAGS
 
@@ -355,7 +356,7 @@ CF_DISABLE_ECHO
 
 CF_ENABLE_WARNINGS(Wno-unknown-pragmas Wswitch-enum,yes)
 if test "x$enable_warnings" = "xyes"; then
-       CF_ADD_ADAFLAGS(-gnatg)
+       CF_ADD_ADAFLAGS(-gnatwa -gnatyg)
 fi
 
 ###    use option --enable-assertions to turn on generation of assertion code
@@ -418,6 +419,7 @@ CF_DISABLE_GNAT_PROJECTS
 ###    Checks for libraries.
 case $cf_cv_system_name in
 (*mingw32*)
+       CF_CHECK_LIBSSP
        ;;
 (*)
 AC_CHECK_FUNC(gettimeofday,