]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 5.9 - patch 20120331
[ncurses.git] / Ada95 / configure.in
index ab70671cccc355c10863ccbb8f3f235eb6b0a85e..d1a29acb099d8bd91df338c1152a146927e2c59b 100644 (file)
@@ -28,14 +28,14 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.39 2012/03/17 16:16:10 tom Exp $
+dnl $Id: configure.in,v 1.40 2012/03/31 22:57:57 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
 dnl See http://invisible-island.net/autoconf/ for additional information.
 dnl
 dnl ---------------------------------------------------------------------------
 AC_PREREQ(2.13.20020210)
-AC_REVISION($Revision: 1.39 $)
+AC_REVISION($Revision: 1.40 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
@@ -54,7 +54,7 @@ cf_user_CFLAGS="$CFLAGS"
 CF_CFG_DEFAULTS
 
 ###    Checks for programs.
-AC_PROG_CC
+AC_PROG_CC(gnatgcc gcc cc)
 CF_GCC_VERSION
 
 AC_PROG_CPP
@@ -485,18 +485,7 @@ dnl At the moment we support no other Ada95 compiler.
 if test "$cf_with_ada" != "no" ; then
        CF_PROG_GNAT
        if test "$cf_cv_prog_gnat_correct" = yes; then
-
-               # make ADAFLAGS consistent with CFLAGS
-               case "$CFLAGS" in
-               *-g*)
-                       CF_ADD_ADAFLAGS(-g)
-                       ;;
-               esac
-               case "$CFLAGS" in
-               *-O*)
-                       CF_ADD_ADAFLAGS(-O3)
-                       ;;
-               esac
+               CF_FIXUP_ADAFLAGS
 
                CF_GNAT_GENERICS
                CF_GNAT_SIGINT