]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - Ada95/configure.in
ncurses 6.2 - patch 20210102
[ncurses.git] / Ada95 / configure.in
index c917a48aece8ded2b1d1bff479be7ea45c477a23..f0f1e5482fbe5d2e76d746182a9af65f2585c83e 100644 (file)
@@ -1,5 +1,6 @@
 dnl***************************************************************************
-dnl Copyright (c) 2010-2016,2018 Free Software Foundation, Inc.              *
+dnl Copyright 2018-2019,2020 Thomas E. Dickey                                *
+dnl Copyright 2010-2016,2018 Free Software Foundation, Inc.                  *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,17 +29,21 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey
 dnl
-dnl $Id: configure.in,v 1.68 2018/11/10 22:08:09 tom Exp $
+dnl $Id: configure.in,v 1.79 2020/12/05 21:40:57 tom Exp $
 dnl Process this file with autoconf to produce a configure script.
 dnl
-dnl See https://invisible-island.net/autoconf/ for additional information.
+dnl For additional information, see
+dnl     https://invisible-island.net/autoconf/
+dnl     https://invisible-island.net/autoconf/my-autoconf.html
 dnl
 dnl ---------------------------------------------------------------------------
-AC_PREREQ(2.52.20030208)
-AC_REVISION($Revision: 1.68 $)
+AC_PREREQ(2.52.20200111)
+AC_REVISION($Revision: 1.79 $)
 AC_INIT(gen/gen.c)
 AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
 
+AC_DEFUN([AC_PATH_XTRA],[])dnl ignore dependencies on this
+
 CF_TOP_BUILDDIR
 
 CF_HELP_MESSAGE(General Options:)
@@ -210,27 +215,7 @@ fi
 CF_HELP_MESSAGE(Fine-Tuning Your Configuration:)
 
 ###   use option --enable-broken-linker to force on use of broken-linker support
-AC_MSG_CHECKING(if you want broken-linker support code)
-AC_ARG_ENABLE(broken_linker,
-       [  --enable-broken_linker  compile with broken-linker support code],
-       [with_broken_linker=$enableval],
-       [with_broken_linker=${BROKEN_LINKER:-no}])
-AC_MSG_RESULT($with_broken_linker)
-
-BROKEN_LINKER=0
-if test "$with_broken_linker" = yes ; then
-       AC_DEFINE(BROKEN_LINKER)
-       BROKEN_LINKER=1
-elif test "$DFT_LWR_MODEL" = shared ; then
-       case $cf_cv_system_name in
-       (cygwin*)
-               AC_DEFINE(BROKEN_LINKER)
-               BROKEN_LINKER=1
-               CF_VERBOSE(cygwin linker is broken anyway)
-               ;;
-       esac
-fi
-AC_SUBST(BROKEN_LINKER)
+CF_ENABLE_BROKEN_LINKER
 
 # Check to define _XOPEN_SOURCE "automatically"
 CF_XOPEN_SOURCE(600)
@@ -375,11 +360,10 @@ AC_ARG_ENABLE(warnings,
        [with_warnings=$enableval])
 AC_MSG_RESULT($with_warnings)
 
+CF_ENABLE_WARNINGS(Wno-unknown-pragmas Wswitch-enum,yes)
 if test "x$with_warnings" = "xyes"; then
        CF_ADD_ADAFLAGS(-gnatg)
-       CF_GCC_WARNINGS(Wno-unknown-pragmas Wswitch-enum)
 fi
-CF_GCC_ATTRIBUTES
 
 ###    use option --enable-assertions to turn on generation of assertion code
 AC_MSG_CHECKING(if you want to enable runtime assertions)
@@ -453,7 +437,7 @@ AC_CHECK_LIB(bsd, gettimeofday,
 esac
 
 ###    Checks for header files.
-AC_CHECK_SIZEOF([signed char], 0)
+AC_CHECK_SIZEOF([signed char])
 AC_STDC_HEADERS
 AC_HEADER_DIRENT
 AC_HEADER_TIME
@@ -497,6 +481,9 @@ if test "$cf_with_ada" != "no" ; then
                CF_WITH_ADA_INCLUDE
                CF_WITH_ADA_OBJECTS
                CF_WITH_ADA_SHAREDLIB
+
+               # allow the Ada binding to be renamed
+               CF_WITH_ADA_LIBNAME(AdaCurses)
        else
                AC_MSG_ERROR(No usable Ada compiler found)
        fi
@@ -545,6 +532,12 @@ if test "$DFT_LWR_MODEL" = shared ; then
        esac
 fi
 
+USE_ARG_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_ARG_SUFFIX)
+
+USE_LIB_SUFFIX=${DFT_ARG_SUFFIX}
+AC_SUBST(USE_LIB_SUFFIX)
+
 USE_CFG_SUFFIX=${DFT_ARG_SUFFIX}
 AC_SUBST(USE_CFG_SUFFIX)
 
@@ -555,9 +548,6 @@ SUB_MAKEFILES="gen/adacurses${USE_ARG_SUFFIX}-config:gen/adacurses-config.in"
 
 AC_DEFINE_UNQUOTED(NCURSES_PATHSEP,'$PATH_SEPARATOR',[Define to override ':' as the library path-separator])
 
-### Now that we're done running tests, add the compiler-warnings, if any
-CF_ADD_CFLAGS($EXTRA_CFLAGS)
-
 ################################################################################
 
 TEST_ARG2=
@@ -600,6 +590,7 @@ AC_SUBST(ADAGEN_LDFLAGS)
 
 AC_OUTPUT( \
        $SUB_MAKEFILES \
+       src/library.gpr:src/library.gpr.in \
        doc/adacurses${DFT_ARG_SUFFIX}-config.1:doc/MKada_config.in \
        Makefile,[
 if test -z "$USE_OLD_MAKERULES" ; then
@@ -620,6 +611,8 @@ NCURSES_MAJOR="$NCURSES_MAJOR"
 NCURSES_MINOR="$NCURSES_MINOR"
 NCURSES_PATCH="$NCURSES_PATCH"
 USE_OLD_MAKERULES="$USE_OLD_MAKERULES"
+cf_cv_VERSION_GNATMAKE=$cf_cv_VERSION_GNATMAKE
+cf_cv_VERSION_GPRBUILD=$cf_cv_VERSION_GPRBUILD
 cf_cv_abi_version="$cf_cv_abi_version"
 cf_cv_rel_version="$cf_cv_rel_version"
 cf_cv_rm_so_locs="$cf_cv_rm_so_locs"