]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/mingw-ncurses.spec
ncurses 6.1 - patch 20180526
[ncurses.git] / package / mingw-ncurses.spec
index 1204a663de5558658dbaeb394dc2875df1e84746..d5aa075de7781bad796f21f2228743f9d1dbe4e7 100644 (file)
@@ -2,12 +2,12 @@
 
 Summary: shared libraries for terminal handling
 Name: mingw32-ncurses6
-Version: 6.0
-Release: 20170819
+Version: 6.1
+Release: 20180526
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
-# URL: http://invisible-island.net/ncurses/
+# URL: https://invisible-island.net/ncurses/
 
 BuildRequires:  mingw32-filesystem >= 95
 BuildRequires:  mingw32-gcc
@@ -17,6 +17,8 @@ BuildRequires:  mingw64-filesystem >= 95
 BuildRequires:  mingw64-gcc
 BuildRequires:  mingw64-binutils
 
+%global MY_ABI 6
+
 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
 
@@ -37,39 +39,43 @@ Cross-compiling support for ncurses to mingw64.
 The ncurses library routines are a terminal-independent method of
 updating character screens with reasonable optimization.
 
-This package is used for testing ABI 6 with cross-compiles to MinGW.
+This package is used for testing ABI %{MY_ABI} with cross-compiles to MinGW.
 
 %prep
 
 %define CFG_OPTS \\\
-       --disable-echo \\\
        --disable-db-install \\\
+       --disable-echo \\\
        --disable-getcap \\\
        --disable-hard-tabs \\\
        --disable-leaks \\\
        --disable-macros \\\
        --disable-overwrite \\\
        --disable-termcap \\\
-       --enable-const \\\
-       --enable-ext-colors \\\
-       --enable-ext-mouse \\\
-       --enable-ext-putwin \\\
        --enable-interop \\\
+       --enable-opaque-curses \\\
+       --enable-opaque-form \\\
+       --enable-opaque-menu \\\
+       --enable-opaque-panel \\\
+       --enable-pc-files \\\
        --enable-sp-funcs \\\
        --enable-term-driver \\\
        --enable-warnings \\\
+       --enable-wgetch-events \\\
        --enable-widec \\\
+       --with-config-suffix=dev \\\
        --verbose \\\
        --with-cxx-shared \\\
        --with-develop \\\
-       --with-fallbacks=unknown,rxvt \\\
+       --with-fallbacks=unknown,xterm \\\
+       --with-install-prefix=$RPM_BUILD_ROOT \\\
+       --with-pc-suffix=%{MY_ABI} \\\
        --with-shared \\\
        --with-tparm-arg=intptr_t \\\
        --with-trace \\\
        --with-xterm-kbs=DEL \\\
        --without-ada \\\
        --without-debug \\\
-       --with-install-prefix=$RPM_BUILD_ROOT \\\
        --without-manpages \\\
        --without-progs \\\
        --without-tests
@@ -82,7 +88,8 @@ mkdir BUILD-W32
 pushd BUILD-W32
 CFLAGS="%{CC_NORMAL}" \
 CC=%{mingw32_cc} \
-%mingw32_configure %{CFG_OPTS}
+%mingw32_configure %{CFG_OPTS} \
+       --with-pkg-config-libdir=%{mingw32_libdir}/pkgconfig
 make
 popd
 
@@ -90,7 +97,8 @@ mkdir BUILD-W64
 pushd BUILD-W64
 CFLAGS="%{CC_NORMAL}" \
 CC=%{mingw64_cc} \
-%mingw64_configure %{CFG_OPTS}
+%mingw64_configure %{CFG_OPTS} \
+       --with-pkg-config-libdir=%{mingw64_libdir}/pkgconfig
 make
 popd
 
@@ -136,6 +144,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %changelog
 
+* Sat Feb 10 2018 Thomas E. Dickey
+- add several development features
+
+* Tue Dec 26 2017 Thomas E. Dickey
+- add --with-config-suffix option
+
 * Sat Sep 20 2014 Thomas E. Dickey
 - adjust install-rules for ncurses*-config