]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/ncurses.spec
ncurses 5.9 - patch 20140609
[ncurses.git] / package / ncurses.spec
index 4609e8638106b5cd061d7881213d32f800d77493..8a991c2ec3562f40a1bbbfe1312f8b93dc8d7807 100644 (file)
@@ -1,10 +1,10 @@
 Summary: shared libraries for terminal handling
 Name: ncurses6
-Release: 5.9
-Version: 20121006
+Version: 5.9
+Release: 20140609
 License: X11
 Group: Development/Libraries
-Source: ncurses-%{release}-%{version}.tgz
+Source: ncurses-%{version}-%{release}.tgz
 # URL: http://invisible-island.net/ncurses/
 
 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
@@ -21,7 +21,8 @@ This package is used for testing ABI 6.
 
 %prep
 
-%setup -q -n ncurses-%{release}-%{version}
+%define debug_package %{nil}
+%setup -q -n ncurses-%{version}-%{release}
 
 %build
 CFLAGS="%{CC_NORMAL}" \
@@ -49,11 +50,14 @@ RPATH_LIST=../lib:%{_prefix}/lib \
        --enable-warnings \
        --enable-widec \
        --verbose \
+       --with-chtype=uint32_t \
+       --with-mmask_t=uint32_t \
        --with-develop \
        --with-shared \
        --with-termlib \
        --with-ticlib \
        --with-trace \
+       --with-cxx-shared \
        --with-xterm-kbs=DEL \
        --without-ada \
        --without-debug \
@@ -65,6 +69,8 @@ make
 rm -rf $RPM_BUILD_ROOT
 
 make install.libs install.progs
+rm -f test/ncurses
+( cd test && make ncurses LOCAL_LIBDIR=%{_libdir} && mv ncurses $RPM_BUILD_ROOT/%{_bindir}/ncurses6 )
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -78,5 +84,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %changelog
 
+* Sat Mar 09 2013 Thomas E. Dickey
+- add --with-cxx-shared option to demonstrate c++ binding as shared library
+
+* Sat Oct 27 2012 Thomas E. Dickey
+- add ncurses program as "ncurses6" to provide demonstration.
+
 * Fri Jun 08 2012 Thomas E. Dickey
 - initial version.