]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - package/ncurses.spec
ncurses 6.2 - patch 20211016
[ncurses.git] / package / ncurses.spec
index d394f2653832f9f300a64330fb2ddc03c2089f7e..fe3c2e5bbe823720e8d42b8fc04e258a8b09aae2 100644 (file)
@@ -1,7 +1,7 @@
 Summary: shared libraries for terminal handling
 Name: ncurses6
-Version: 6.1
-Release: 20200104
+Version: 6.2
+Release: 20211016
 License: X11
 Group: Development/Libraries
 Source: ncurses-%{version}-%{release}.tgz
@@ -27,7 +27,10 @@ This package is used for testing ABI %{MY_ABI}.
 %prep
 
 %global is_mandriva %(test -f /etc/mandriva-release && echo 1 || echo 0)
+%global is_fedora   %(test -f /usr/bin/dnf && echo 1 || echo 0)
+%global is_centos   %(test -f /etc/centos-release && echo 1 || echo 0)
 %global is_redhat   %(test -f /etc/redhat-release && echo 1 || echo 0)
+%global is_scilinux %(test -f /etc/sl-release && echo 1 || echo 0)
 %global is_suse     %(test -f /etc/SuSE-release && echo 1 || echo 0)
 
 %if %{is_redhat}
@@ -44,7 +47,7 @@ This package is used for testing ABI %{MY_ABI}.
 %define _disable_ld_build_id 1
 %endif
 
-%if %{is_redhat}
+%if %{is_fedora} || %{is_scilinux} || %{is_centos}
 # workaround for toolset breakage in Fedora 28
 %define _test_relink --enable-relink
 %else
@@ -74,7 +77,8 @@ This package is used for testing ABI %{MY_ABI}.
        --enable-opaque-menu \\\
        --enable-opaque-panel \\\
        --enable-pc-files \\\
-       --enable-rpath \\\
+       --disable-rpath \\\
+       --enable-stdnoreturn \\\
        --enable-warnings \\\
        --enable-wgetch-events \\\
        --enable-widec \\\
@@ -111,10 +115,14 @@ make install.libs install.progs
 rm -f test/ncurses
 ( cd test && make ncurses LOCAL_LIBDIR=%{_libdir} && mv ncurses $RPM_BUILD_ROOT/%{_bindir}/ncurses%{MY_ABI} )
 
-%if %{is_redhat}
+%if %{is_mandriva}
+# check this first because Mageia has the /etc/redhat-release file...
+%else
+%if %{is_fedora}
 %ldconfig_scriptlets libs
 %ldconfig_scriptlets c++-libs
 %endif
+%endif
 
 %clean
 if rm -rf $RPM_BUILD_ROOT; then
@@ -132,6 +140,9 @@ exit 0
 
 %changelog
 
+* Sat Oct 16 2021 Thomas Dickey
+- disable rpath to address QA_RPATHS=1 warning.
+
 * Tue Dec 24 2019 Thomas Dickey
 - drop custom CC_NORMAL warning flags because setting CFLAGS interferes with
   matching Fedora's PIE/PIC configuration.  Also, generate debug/debug-source