]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20120811
[ncurses.git] / test / configure.in
index 808c90243e3747fab17adf2ddcadac678939a3d9..09c3cebe19522c114a8423ae86da2dd89595a2e0 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2010,2011 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2011,2012 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.99 2011/09/24 15:42:11 tom Exp $
+dnl $Id: configure.in,v 1.104 2012/03/17 17:29:03 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -107,56 +107,23 @@ CF_DISABLE_LEAKS
 dnl ---------------------------------------------------------------------------
 AC_MSG_CHECKING(if you want to check for wide-character functions)
 CF_ARG_DISABLE(widec,
-       [--disable-widec           disable checks for wide-character functions],
+       [  --disable-widec           disable checks for wide-character functions],
        cf_enable_widec=no,
        cf_enable_widec=yes,
        yes)
 AC_MSG_RESULT($cf_enable_widec)
 
-CF_WITH_CURSES_DIR
 
 dnl ---------------------------------------------------------------------------
-dnl NcursesW, installed in conventional location
-AC_MSG_CHECKING(for specified curses library type)
-AC_ARG_WITH(ncursesw,
-       [  --with-ncursesw         use wide ncurses-libraries (installed)],
-       [cf_cv_screen=ncursesw],[
-
-dnl Ncurses, installed in conventional location
-AC_ARG_WITH(ncurses,
-       [  --with-ncurses          use ncurses-libraries (installed)],
-       [cf_cv_screen=ncurses],[
-
-AC_ARG_WITH(pdcurses,
-       [  --with-pdcurses         compile/link with pdcurses X11 library],
-       [cf_cv_screen=pdcurses],[
-
-AC_ARG_WITH(curses-colr,
-       [  --with-curses-colr      compile/link with HPUX 10.x color-curses],
-       [cf_cv_screen=curses_colr],[
-
-AC_ARG_WITH(curses-5lib,
-       [  --with-curses-5lib      compile/link with SunOS 5lib curses],
-       [cf_cv_screen=curses_5lib])])])])])
-
-AC_MSG_RESULT($cf_cv_screen)
+CF_WITH_NCURSES_ETC
 
 case $cf_cv_screen in
 curses|curses_*)
-       CF_CURSES_CONFIG
        CF_NETBSD_FORM_H
        CF_NETBSD_MENU_H
        ;;
-ncurses)
-       CF_NCURSES_CONFIG
-       ;;
 ncursesw)
        cf_cv_libtype=w
-       CF_UTF8_LIB
-       CF_NCURSES_CONFIG(ncursesw)
-       ;;
-pdcurses) #(vi
-       CF_PDCURSES_X11
        ;;
 esac
 
@@ -265,6 +232,31 @@ CF_NCURSES_EXT_FUNCS
 
 if test "$cf_enable_widec" = yes
 then
+       # workaround for systems with ncurses before 20111029, due to change of
+       # feature test macro from _XPG5 to _XOPEN_SOURCE
+       if test -n "$cf_cv_ncurses_version" && test "x$cf_cv_ncurses_version" != xno
+       then
+               cf_define_xpg5=no
+               AC_MSG_CHECKING(if _XPG5 should be defined to enable wide-characters)
+
+               AC_TRY_COMPILE([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+                       [int x = _XPG5],,
+                       [cf_save_cppflags="$CPPFLAGS"
+                        CPPFLAGS="$CPPFLAGS -D_XPG5"
+                        AC_TRY_COMPILE([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+                               [int x = _XPG5],
+                               [cf_define_xpg5=yes])
+                        CPPFLAGS="$cf_save_cppflags"])
+               AC_MSG_RESULT($cf_define_xpg5)
+
+               if test "$cf_define_xpg5" = yes
+               then
+                       CPPFLAGS="$CPPFLAGS -D_XPG5"
+               fi
+       fi
+
        AC_CACHE_CHECK(for wide-character functions,cf_cv_widechar_funcs,[
        AC_TRY_LINK([
 #include <${cf_cv_ncurses_header:-curses.h}>],
@@ -317,6 +309,8 @@ fi
 CF_CURSES_CHECK_DATA(boolnames)
 CF_CURSES_CHECK_DATA(boolfnames)
 
+CF_DISABLE_RPATH_HACK
+
 TEST_ARGS="$LIBS"
 LIBS=
 
@@ -339,7 +333,8 @@ do
 \$(MODEL)/$N.o : \$(srcdir)/$N.c \\
        \$(srcdir)/test.priv.h \\
        ncurses_cfg.h
-       @echo compiling $N; \$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
+       $SHOW_CC
+       $ECHO_CC\$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
 TEST_EOF
 done
 
@@ -354,5 +349,7 @@ TEST_EOF
 fi
 ],[
 AWK="$AWK"
+ECHO_CC="$ECHO_CC"
 ECHO_LD="$ECHO_LD"
+SHOW_CC="$SHOW_LD"
 ],cat)