]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 6.5 - patch 20240504
[ncurses.git] / test / configure.in
index e74643e9bbac8a71bcbf12b15ef7605d563c2af3..4df1c11f933b9940a091fb82efc4b522143a737c 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright 2018-2021,2022 Thomas E. Dickey                                *
+dnl Copyright 2018-2023,2024 Thomas E. Dickey                                *
 dnl Copyright 1998-2017,2018 Free Software Foundation, Inc.                  *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
@@ -29,7 +29,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996-on
 dnl
-dnl $Id: configure.in,v 1.164 2022/04/09 21:31:37 tom Exp $
+dnl $Id: configure.in,v 1.174 2024/03/30 14:31:11 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -108,6 +108,7 @@ AC_OBJEXT
 CF_GCC_ATTRIBUTES
 CF_ENABLE_STRING_HACKS
 CF_XOPEN_SOURCE(600)
+AC_CHECK_DECL(exit)
 CF_SIG_ATOMIC_T
 
 # Work around breakage on OS X
@@ -237,14 +238,12 @@ fi
 # look for curses-related headers
 AC_CHECK_HEADERS( $cf_curses_headers )
 
-AC_STDC_HEADERS
 AC_HEADER_TIME
 AC_CHECK_HEADERS( \
 getopt.h \
 locale.h \
 math.h \
 stdarg.h \
-stdint.h \
 sys/ioctl.h \
 sys/select.h \
 sys/time.h \
@@ -253,10 +252,10 @@ unistd.h \
 )
 
 CF_GETOPT_HEADER
+CF_FUNC_GETTIME
 
 AC_CHECK_FUNCS( \
 getopt \
-gettimeofday \
 snprintf \
 strdup \
 strstr \
@@ -317,12 +316,15 @@ wcstombs \
 fi
 
 CF_CURSES_FUNCS( \
+_nc_tparm_analyze \
+_tracef \
 alloc_pair \
 assume_default_colors \
 chgat \
 color_content \
 color_set \
 copywin \
+curses_trace \
 delscreen \
 dupwin \
 exit_curses \
@@ -357,6 +359,9 @@ termname \
 tgetent \
 tigetnum \
 tigetstr \
+tiparm \
+tiparm_s \
+tiscan_s \
 tputs_sp \
 typeahead \
 unget_wch \
@@ -374,7 +379,6 @@ winsdelln \
 winsstr \
 wresize \
 wsyncdown \
-_tracef \
 )
 
 CF_TPUTS_PROTO