]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 6.0 - patch 20170513
[ncurses.git] / test / configure.in
index c88e3627c4ace7dca79e04f974ccb6acbeec5989..85c0b1b5ad9ee33bcf06eb1c7f154fb3c1deb2c1 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2013,2014 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2016,2017 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -26,9 +26,9 @@ dnl sale, use or other dealings in this Software without prior written       *
 dnl authorization.                                                           *
 dnl***************************************************************************
 dnl
-dnl Author: Thomas E. Dickey 1996, etc.
+dnl Author: Thomas E. Dickey 1996-on
 dnl
-dnl $Id: configure.in,v 1.115 2014/07/19 23:05:32 tom Exp $
+dnl $Id: configure.in,v 1.130 2017/03/31 12:15:36 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -36,7 +36,9 @@ dnl
 dnl If you're configuring ncurses, you shouldn't need to use this script.
 dnl It's only for testing purposes.
 dnl
-dnl See http://invisible-island.net/autoconf/ for additional information.
+dnl For additional information, see
+dnl            http://invisible-island.net/autoconf/
+dnl            http://invisible-island.net/ncurses/ncurses-examples.html
 dnl ---------------------------------------------------------------------------
 AC_PREREQ(2.52.20030208)
 AC_INIT(ncurses.c)
@@ -73,11 +75,13 @@ LDFLAGS_STATIC=""                           AC_SUBST(LDFLAGS_STATIC)
 LD_MODEL=""                                            AC_SUBST(LD_MODEL)
 LD_SHARED_OPTS=""                              AC_SUBST(LD_SHARED_OPTS)
 LIBTOOL=""                                             AC_SUBST(LIBTOOL)
+LIBTOOL_OPTS=""                                        AC_SUBST(LIBTOOL_OPTS)
 LIB_CLEAN=""                                   AC_SUBST(LIB_CLEAN)
 LIB_COMPILE=""                                 AC_SUBST(LIB_COMPILE)
 LIB_LINK='${CC}'                               AC_SUBST(LIB_LINK)
 LINK_TESTS=""                                  AC_SUBST(LINK_TESTS)
 LOCAL_LDFLAGS=""                               AC_SUBST(LOCAL_LDFLAGS)
+PACKAGE="ncurses-examples"             AC_SUBST(PACKAGE)
 PTHREAD="-lm"                                  AC_SUBST(PTHREAD)
 TEST_ARGS=""                                   AC_SUBST(TEST_ARGS)
 TEST_DEPS=""                                   AC_SUBST(TEST_DEPS)
@@ -95,9 +99,16 @@ AC_EXEEXT
 AC_OBJEXT
 
 CF_GCC_ATTRIBUTES
+CF_ENABLE_STRING_HACKS
 CF_XOPEN_SOURCE
 CF_SIG_ATOMIC_T
 
+# Work around breakage on OS X
+CF_SIGWINCH
+
+# Checks for CODESET support.
+AM_LANGINFO_CODESET
+
 dnl ---------------------------------------------------------------------------
 CF_HELP_MESSAGE(General Options:)
 CF_PKG_CONFIG
@@ -120,13 +131,13 @@ CF_HELP_MESSAGE(Curses Version-dependent Options:)
 CF_WITH_NCURSES_ETC
 
 case $cf_cv_screen in
-curses|curses_*)
+(ncurses*)
+       cf_cv_libtype=`echo "$cf_cv_screen" | sed -e 's/^ncurses//'`
+       ;;
+(curses|curses_*)
        CF_NETBSD_FORM_H
        CF_NETBSD_MENU_H
        ;;
-ncursesw)
-       cf_cv_libtype=w
-       ;;
 esac
 
 dnl If we've not specified a library, assume we're using sysvr4 libraries
@@ -134,17 +145,14 @@ dnl installed conventionally (e.g., SunOS 5.x - solaris).
 
 dnl Autoconf builds up the $LIBS in reverse order
 
-case $cf_cv_screen in #(vi
-pdcurses) #(vi
+case $cf_cv_screen in
+(pdcurses)
        ;;
-*)
+(*)
        # look for curses-related libraries
-       : ${cf_panel_lib:=panel}
-       : ${cf_menu_lib:=menu}
-       : ${cf_form_lib:=form}
-       AC_CHECK_LIB($cf_panel_lib$cf_cv_libtype,new_panel)
-       AC_CHECK_LIB($cf_menu_lib$cf_cv_libtype,menu_driver)
-       AC_CHECK_LIB($cf_form_lib$cf_cv_libtype,form_driver)
+       CF_CHECK_CURSES_LIB(panel,$cf_cv_libtype,new_panel)
+       CF_CHECK_CURSES_LIB(menu,$cf_cv_libtype,menu_driver)
+       CF_CHECK_CURSES_LIB(form,$cf_cv_libtype,form_driver)
 
        # look for curses-related headers
        AC_CHECK_HEADERS( \
@@ -175,9 +183,14 @@ unistd.h \
 CF_GETOPT_HEADER
 
 AC_CHECK_FUNCS( \
+getopt \
 gettimeofday \
 )
 
+if test "x$ac_cv_func_getopt" = xno; then
+       AC_MSG_ERROR(getopt is required for building programs)
+fi
+
 if test "$cf_enable_widec" = yes; then
 AC_CHECK_FUNCS( \
 mblen \
@@ -192,6 +205,7 @@ wcstombs \
 fi
 
 CF_CURSES_FUNCS( \
+alloc_pair \
 assume_default_colors \
 chgat \
 color_set \
@@ -202,12 +216,14 @@ getmaxx \
 getnstr \
 getparx \
 getwin \
+init_extended_color \
 mvvline \
 mvwvline \
 napms \
 putwin \
 resize_term \
 resizeterm \
+restartterm \
 ripoffline \
 scr_dump \
 setupterm \
@@ -217,9 +233,11 @@ termattrs \
 tgetent \
 tigetnum \
 tigetstr \
+tputs_sp \
 typeahead \
 use_default_colors \
 use_env \
+use_extended_names \
 use_screen \
 use_window \
 vid_puts \
@@ -282,7 +300,32 @@ else
        AC_DEFINE(USE_WIDEC_SUPPORT,0)
 fi
 
+AC_CACHE_CHECK(if $cf_cv_screen library uses pthreads,cf_cv_use_pthreads,[
+AC_TRY_LINK([
+#include <${cf_cv_ncurses_header:-curses.h}>
+extern void _nc_init_pthreads(void);
+],
+[
+       initscr();
+       _nc_init_pthreads();
+       ],
+       [cf_cv_use_pthreads=yes],
+       [cf_cv_use_pthreads=no])
+])
+test $cf_cv_use_pthreads = yes && AC_DEFINE(USE_PTHREADS)
+
 CF_SYS_TIME_SELECT
+
+# special check for test/ditto.c
+CF_FUNC_OPENPTY
+if test "$cf_cv_func_openpty" != no ; then
+       AC_DEFINE_UNQUOTED(USE_OPENPTY_HEADER,<$cf_cv_func_openpty>,[Define to actual header for openpty function])
+       AC_DEFINE(USE_XTERM_PTY,1,[Define to 1 if we should assume xterm pseudoterminal interface])
+       if test "x$cf_cv_lib_util" = xyes ; then
+               CF_ADD_LIB(util,TEST_LIBS)
+       fi
+fi
+
 CF_FUNC_CURSES_VERSION
 
 CF_CURSES_ACS_MAP
@@ -311,8 +354,10 @@ if test "$cf_enable_widec" = yes; then
        fi
 fi
 
+CF_CURSES_CHECK_DATA(ospeed)
 CF_CURSES_CHECK_DATA(boolnames)
 CF_CURSES_CHECK_DATA(boolfnames)
+CF_CURSES_CHECK_DATA(ttytype)
 
 dnl ---------------------------------------------------------------------------
 CF_HELP_MESSAGE(Testing/development Options:)