]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20131005
[ncurses.git] / test / configure.in
index 451cc018bab141a2f09624194ba46ea14494c48a..a1044ba72e16314dbb0c948ec4d42c85b9b9a6da 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
 dnl***************************************************************************
-dnl Copyright (c) 1998-2011,2012 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2012,2013 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.109 2012/11/03 19:26:33 tom Exp $
+dnl $Id: configure.in,v 1.112 2013/05/18 21:53:54 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -56,7 +56,7 @@ CF_PROG_INSTALL
 CF_PROG_LINT
 CF_MAKE_TAGS
 
 CF_PROG_LINT
 CF_MAKE_TAGS
 
-CF_MATH_LIB(MATH_LIB,sin(x))
+CF_MATH_LIB(MATH_LIB,pow(sin(x),x))
 AC_SUBST(MATH_LIB)
 
 dnl Things that we don't need (or must override) if we're not building ncurses
 AC_SUBST(MATH_LIB)
 
 dnl Things that we don't need (or must override) if we're not building ncurses
@@ -138,9 +138,12 @@ pdcurses) #(vi
        ;;
 *)
        # look for curses-related libraries
        ;;
 *)
        # look for curses-related libraries
-       AC_CHECK_LIB(panel$cf_cv_libtype,new_panel)
-       AC_CHECK_LIB(menu$cf_cv_libtype,menu_driver)
-       AC_CHECK_LIB(form$cf_cv_libtype,form_driver)
+       : ${cf_panel_lib:=panel}
+       : ${cf_menu_lib:=menu}
+       : ${cf_form_lib:=form}
+       AC_CHECK_LIB($cf_panel_lib$cf_cv_libtype,new_panel)
+       AC_CHECK_LIB($cf_menu_lib$cf_cv_libtype,menu_driver)
+       AC_CHECK_LIB($cf_form_lib$cf_cv_libtype,form_driver)
 
        # look for curses-related headers
        AC_CHECK_HEADERS( \
 
        # look for curses-related headers
        AC_CHECK_HEADERS( \
@@ -154,8 +157,6 @@ pdcurses) #(vi
        ;;
 esac
 
        ;;
 esac
 
-AC_TYPE_SIGNAL
-
 AC_STDC_HEADERS
 AC_HEADER_TIME
 AC_CHECK_HEADERS( \
 AC_STDC_HEADERS
 AC_HEADER_TIME
 AC_CHECK_HEADERS( \