]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 5.9 - patch 20111030
[ncurses.git] / test / configure.in
index 2efb6d010e9c1dde44bb6a8e3c59bbcfdd29b0c2..d72a67b401ed3f2ce52a8e77ec6a2943c17ea4b2 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
-dnl Copyright (c) 1998-2009,2010 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2010,2011 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996, etc.
 dnl
-dnl $Id: configure.in,v 1.82 2010/11/06 23:05:15 tom Exp $
+dnl $Id: configure.in,v 1.101 2011/10/29 21:17:36 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -60,6 +60,7 @@ CF_MATH_LIB(MATH_LIB,sin(x))
 AC_SUBST(MATH_LIB)
 
 dnl Things that we don't need (or must override) if we're not building ncurses
+CF_TOP_BUILDDIR
 CC_G_OPT="-g"                                  AC_SUBST(CC_G_OPT)
 CC_SHARED_OPTS=unknown                 AC_SUBST(CC_SHARED_OPTS)
 CPPFLAGS="$CPPFLAGS"                   AC_SUBST(CPPFLAGS)
@@ -81,7 +82,8 @@ PTHREAD="-lm"                                 AC_SUBST(PTHREAD)
 TEST_ARGS=""                                   AC_SUBST(TEST_ARGS)
 TEST_DEPS=""                                   AC_SUBST(TEST_DEPS)
 TEST_LIBS=""                                   AC_SUBST(TEST_LIBS)
-TINFO_ARGS='$(LIBS_CURSES)'            AC_SUBST(TINFO_ARGS)
+TINFO_LDFLAGS=''                               AC_SUBST(TINFO_LDFLAGS)
+TINFO_LIBS='$(LIBS_CURSES)'            AC_SUBST(TINFO_LIBS)
 cf_cv_abi_version=""                   AC_SUBST(cf_cv_abi_version)
 cf_cv_rel_version=""                   AC_SUBST(cf_cv_rel_version)
 
@@ -100,16 +102,22 @@ CF_SIG_ATOMIC_T
 CF_DISABLE_ECHO
 CF_ENABLE_WARNINGS
 
-CF_WITH_CURSES_DIR
+CF_DISABLE_LEAKS
+
+dnl ---------------------------------------------------------------------------
+AC_MSG_CHECKING(if you want to check for wide-character functions)
+CF_ARG_DISABLE(widec,
+       [  --disable-widec           disable checks for wide-character functions],
+       cf_enable_widec=no,
+       cf_enable_widec=yes,
+       yes)
+AC_MSG_RESULT($cf_enable_widec)
 
-dnl SunOS 4.x
-AC_ARG_WITH(5lib,
-       [  --with-5lib             use SunOS sysv-libraries],
-       [LIBS="-L/usr/5lib $LIBS"
-        CPPFLAGS="$CPPFLAGS -I/usr/5include"])
+CF_WITH_CURSES_DIR
 
 dnl ---------------------------------------------------------------------------
 dnl NcursesW, installed in conventional location
+AC_MSG_CHECKING(for specified curses library type)
 AC_ARG_WITH(ncursesw,
        [  --with-ncursesw         use wide ncurses-libraries (installed)],
        [cf_cv_screen=ncursesw],[
@@ -121,11 +129,23 @@ AC_ARG_WITH(ncurses,
 
 AC_ARG_WITH(pdcurses,
        [  --with-pdcurses         compile/link with pdcurses X11 library],
-       [cf_cv_screen=pdcurses])])])
+       [cf_cv_screen=pdcurses],[
+
+AC_ARG_WITH(curses-colr,
+       [  --with-curses-colr      compile/link with HPUX 10.x color-curses],
+       [cf_cv_screen=curses_colr],[
+
+AC_ARG_WITH(curses-5lib,
+       [  --with-curses-5lib      compile/link with SunOS 5lib curses],
+       [cf_cv_screen=curses_5lib])])])])])
+
+AC_MSG_RESULT($cf_cv_screen)
 
 case $cf_cv_screen in
-curses)
+curses|curses_*)
        CF_CURSES_CONFIG
+       CF_NETBSD_FORM_H
+       CF_NETBSD_MENU_H
        ;;
 ncurses)
        CF_NCURSES_CONFIG
@@ -161,6 +181,7 @@ pdcurses) #(vi
                form.h \
                menu.h \
                panel.h \
+               term_entry.h \
                )
        ;;
 esac
@@ -172,6 +193,7 @@ AC_HEADER_TIME
 AC_CHECK_HEADERS( \
 getopt.h \
 locale.h \
+math.h \
 stdarg.h \
 sys/ioctl.h \
 sys/select.h \
@@ -180,20 +202,28 @@ termios.h \
 unistd.h \
 )
 
+CF_GETOPT_HEADER
+
 AC_CHECK_FUNCS( \
 gettimeofday \
+strdup \
+)
+
+if test "$cf_enable_widec" = yes; then
+AC_CHECK_FUNCS( \
 mblen \
 mbrlen \
 mbrtowc \
 mbsrtowcs \
 mbstowcs \
 mbtowc \
-strdup \
 wcsrtombs \
 wcstombs \
 )
+fi
 
 CF_CURSES_FUNCS( \
+assume_default_colors \
 chgat \
 color_set \
 filter \
@@ -210,6 +240,7 @@ putwin \
 resize_term \
 resizeterm \
 ripoffline \
+scr_dump \
 setupterm \
 slk_color \
 slk_init \
@@ -219,59 +250,100 @@ tigetnum \
 tigetstr \
 typeahead \
 use_default_colors \
-vw_printw \
+use_screen \
+use_window \
 vsscanf \
+vw_printw \
 wchgat \
 winsstr \
 wresize \
+wsyncdown \
 )
 
+CF_TPUTS_PROTO
 CF_NCURSES_EXT_FUNCS
 
-AC_CACHE_CHECK(for wide-character functions,cf_cv_widechar_funcs,[
-AC_TRY_LINK([
+if test "$cf_enable_widec" = yes
+then
+       # workaround for systems with ncurses before 20111029, due to change of
+       # feature test macro from _XPG5 to _XOPEN_SOURCE
+       if test -n "$cf_cv_ncurses_version" && test "x$cf_cv_ncurses_version" != xno
+       then
+               cf_define_xpg5=no
+               AC_MSG_CHECKING(if _XPG5 should be defined to enable wide-characters)
+
+               AC_TRY_COMPILE([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+                       [int x = _XPG5],,
+                       [cf_save_cppflags="$CPPFLAGS"
+                        CPPFLAGS="$CPPFLAGS -D_XPG5"
+                        AC_TRY_COMPILE([
 #include <${cf_cv_ncurses_header:-curses.h}>],
-[
-       static wchar_t src_wchar[2];
-       static cchar_t dst_cchar;
-       setcchar(&dst_cchar, src_wchar, A_NORMAL, 0, (void *) 0);
-       ],
-       [cf_cv_widechar_funcs=yes],
-       [cf_cv_widechar_funcs=no])
-])
-if test "$cf_cv_widechar_funcs" != no ; then
-       AC_DEFINE(USE_WIDEC_SUPPORT,1)
+                               [int x = _XPG5],
+                               [cf_define_xpg5=yes])
+                        CPPFLAGS="$cf_save_cppflags"])
+               AC_MSG_RESULT($cf_define_xpg5)
+
+               if test "$cf_define_xpg5" = yes
+               then
+                       CPPFLAGS="$CPPFLAGS -D_XPG5"
+               fi
+       fi
+
+       AC_CACHE_CHECK(for wide-character functions,cf_cv_widechar_funcs,[
+       AC_TRY_LINK([
+#include <${cf_cv_ncurses_header:-curses.h}>],
+       [
+               static wchar_t src_wchar[2];
+               static cchar_t dst_cchar;
+               setcchar(&dst_cchar, src_wchar, A_NORMAL, 0, (void *) 0);
+               ],
+               [cf_cv_widechar_funcs=yes],
+               [cf_cv_widechar_funcs=no])
+       ])
+       if test "$cf_cv_widechar_funcs" != no ; then
+               AC_DEFINE(USE_WIDEC_SUPPORT,1)
+       else
+               AC_DEFINE(USE_WIDEC_SUPPORT,0)
+       fi
 else
        AC_DEFINE(USE_WIDEC_SUPPORT,0)
 fi
 
-AC_FUNC_VFORK
 CF_SYS_TIME_SELECT
 CF_FUNC_CURSES_VERSION
 CF_CURSES_ACS_MAP
-CF_CURSES_WACS_MAP
+
+if test "$cf_enable_widec" = yes; then
+       CF_CURSES_WACS_MAP
+       CF_CURSES_WACS_SYMBOLS
+fi
 
 CF_CURSES_CHECK_TYPE(attr_t,long)
 
-CF_WCHAR_TYPE(mbstate_t, NCURSES_MBSTATE_T, NCURSES_OK_MBSTATE_T)
-CF_WCHAR_TYPE(wchar_t,   NCURSES_WCHAR_T,   NCURSES_OK_WCHAR_T)
-CF_WCHAR_TYPE(wint_t,    NCURSES_WINT_T,    NCURSES_OK_WINT_T)
+if test "$cf_enable_widec" = yes; then
+       CF_WCHAR_TYPE(mbstate_t, NCURSES_MBSTATE_T, NCURSES_OK_MBSTATE_T)
+       CF_WCHAR_TYPE(wchar_t,   NCURSES_WCHAR_T,   NCURSES_OK_WCHAR_T)
+       CF_WCHAR_TYPE(wint_t,    NCURSES_WINT_T,    NCURSES_OK_WINT_T)
 
-if test "$NCURSES_OK_MBSTATE_T" = 0 ; then
-       CF_CURSES_CHECK_TYPE(mbstate_t,long)
-fi
+       if test "$NCURSES_OK_MBSTATE_T" = 0 ; then
+               CF_CURSES_CHECK_TYPE(mbstate_t,long)
+       fi
 
-if test "$NCURSES_OK_WCHAR_T" = 0 ; then
-       CF_CURSES_CHECK_TYPE(wchar_t,long)
-fi
+       if test "$NCURSES_OK_WCHAR_T" = 0 ; then
+               CF_CURSES_CHECK_TYPE(wchar_t,long)
+       fi
 
-if test "$NCURSES_OK_WINT_T" = 0 ; then
-       CF_CURSES_CHECK_TYPE(wint_t,long)
+       if test "$NCURSES_OK_WINT_T" = 0 ; then
+               CF_CURSES_CHECK_TYPE(wint_t,long)
+       fi
 fi
 
 CF_CURSES_CHECK_DATA(boolnames)
 CF_CURSES_CHECK_DATA(boolfnames)
 
+CF_DISABLE_RPATH_HACK
+
 TEST_ARGS="$LIBS"
 LIBS=
 
@@ -291,10 +363,10 @@ for N in $LIST
 do
        cat >>Makefile <<TEST_EOF
 
-\$(MODEL)/$N.o : $N.c \\
-       test.priv.h \\
+\$(MODEL)/$N.o : \$(srcdir)/$N.c \\
+       \$(srcdir)/test.priv.h \\
        ncurses_cfg.h
-       @echo compiling $N; \$(CC) -c \$(CFLAGS_DEFAULT) $N.c
+       @echo compiling $N; \$(CC) -c \$(CFLAGS_DEFAULT) \$(srcdir)/$N.c
 TEST_EOF
 done