]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 6.1 - patch 20190202
[ncurses.git] / test / configure.in
index 3d8eebd0a74aff5bd79d39c1babbd232d1947aa1..dec48a18594b7c519de3383bb2983a25d65205ba 100644 (file)
@@ -1,5 +1,5 @@
 dnl***************************************************************************
 dnl***************************************************************************
-dnl Copyright (c) 1998-2017,2018 Free Software Foundation, Inc.              *
+dnl Copyright (c) 1998-2018,2019 Free Software Foundation, Inc.              *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
 dnl                                                                          *
 dnl Permission is hereby granted, free of charge, to any person obtaining a  *
 dnl copy of this software and associated documentation files (the            *
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996-on
 dnl
 dnl
 dnl Author: Thomas E. Dickey 1996-on
 dnl
-dnl $Id: configure.in,v 1.150 2018/06/17 01:22:00 tom Exp $
+dnl $Id: configure.in,v 1.152 2019/02/02 19:57:53 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -250,7 +250,6 @@ CF_GETOPT_HEADER
 AC_CHECK_FUNCS( \
 getopt \
 gettimeofday \
 AC_CHECK_FUNCS( \
 getopt \
 gettimeofday \
-tdestroy \
 tsearch \
 )
 
 tsearch \
 )
 
@@ -258,12 +257,37 @@ tsearch \
 AC_CACHE_CHECK(if we can use termcap.h,cf_cv_have_termcap_h,[
        AC_TRY_COMPILE([
 #include <curses.h>
 AC_CACHE_CHECK(if we can use termcap.h,cf_cv_have_termcap_h,[
        AC_TRY_COMPILE([
 #include <curses.h>
+#ifdef NCURSES_VERSION
+#undef NCURSES_VERSION
+#endif
 #include <termcap.h>
 #include <termcap.h>
+#ifndef NCURSES_VERSION
+#error wrong header
+#endif
 ],
        [return 0;],
        [cf_cv_have_termcap_h=yes],
        [cf_cv_have_termcap_h=no])])
 ],
        [return 0;],
        [cf_cv_have_termcap_h=yes],
        [cf_cv_have_termcap_h=no])])
-test "x$cf_cv_have_termcap_h" = xyes && AC_DEFINE(HAVE_TERMCAP_H)
+if test "x$cf_cv_have_termcap_h" = xyes
+then
+       AC_DEFINE(HAVE_TERMCAP_H)
+else
+AC_CACHE_CHECK(if we can use ncurses/termcap.h,cf_cv_have_ncurses_termcap_h,[
+       AC_TRY_COMPILE([
+#include <ncurses/curses.h>
+#ifdef NCURSES_VERSION
+#undef NCURSES_VERSION
+#endif
+#include <ncurses/termcap.h>
+#ifndef NCURSES_VERSION
+#error wrong header
+#endif
+],
+       [return 0;],
+       [cf_cv_have_ncurses_termcap_h=yes],
+       [cf_cv_have_ncurses_termcap_h=no])])
+test "x$cf_cv_have_ncurses_termcap_h" = xyes && AC_DEFINE(HAVE_NCURSES_TERMCAP_H)
+fi
 
 if test "x$ac_cv_func_getopt" = xno; then
        AC_MSG_ERROR(getopt is required for building programs)
 
 if test "x$ac_cv_func_getopt" = xno; then
        AC_MSG_ERROR(getopt is required for building programs)