]> ncurses.scripts.mit.edu Git - ncurses.git/blobdiff - test/configure.in
ncurses 6.1 - patch 20200104
[ncurses.git] / test / configure.in
index daba64a209b30f793b8afc51087d9fed0ed1f589..f47b33fb4fa565ec358a1e91907eae30c937f1a5 100644 (file)
@@ -28,7 +28,7 @@ dnl***************************************************************************
 dnl
 dnl Author: Thomas E. Dickey 1996-on
 dnl
-dnl $Id: configure.in,v 1.154 2019/04/13 22:51:52 tom Exp $
+dnl $Id: configure.in,v 1.155 2019/12/31 09:42:42 tom Exp $
 dnl This is a simple configuration-script for the ncurses test programs that
 dnl allows the test-directory to be separately configured against a reference
 dnl system (i.e., sysvr4 curses)
@@ -271,7 +271,7 @@ AC_CACHE_CHECK(if we can use termcap.h,cf_cv_have_termcap_h,[
        [cf_cv_have_termcap_h=no])])
 if test "x$cf_cv_have_termcap_h" = xyes
 then
-       AC_DEFINE(HAVE_TERMCAP_H)
+       AC_DEFINE(HAVE_TERMCAP_H,1,[Define to 1 if we can use termcap.h])
 else
 AC_CACHE_CHECK(if we can use ncurses/termcap.h,cf_cv_have_ncurses_termcap_h,[
        AC_TRY_COMPILE([
@@ -287,7 +287,7 @@ AC_CACHE_CHECK(if we can use ncurses/termcap.h,cf_cv_have_ncurses_termcap_h,[
        [return 0;],
        [cf_cv_have_ncurses_termcap_h=yes],
        [cf_cv_have_ncurses_termcap_h=no])])
-test "x$cf_cv_have_ncurses_termcap_h" = xyes && AC_DEFINE(HAVE_NCURSES_TERMCAP_H)
+test "x$cf_cv_have_ncurses_termcap_h" = xyes && AC_DEFINE(HAVE_NCURSES_TERMCAP_H,1,[Define to 1 if we can use ncurses/termcap.h])
 fi
 
 if test "x$ac_cv_func_getopt" = xno; then
@@ -426,7 +426,7 @@ extern void _nc_init_pthreads(void);
        [cf_cv_use_pthreads=yes],
        [cf_cv_use_pthreads=no])
 ])
-test $cf_cv_use_pthreads = yes && AC_DEFINE(USE_PTHREADS)
+test $cf_cv_use_pthreads = yes && AC_DEFINE(USE_PTHREADS,1,[Define to 1 if $cf_cv_screen library uses pthreads])
 
 CF_SYS_TIME_SELECT